Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83228

Summary: kernel-smp-* installation stalls if there is ls240 media in the ls240 drive
Product: Red Hat Enterprise Linux 2.1 Reporter: Larry Troan <ltroan>
Component: kernelAssignee: Jason Baron <jbaron>
Status: CLOSED CURRENTRELEASE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 2.1CC: ichute, knoel, lwoodman, tao
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: INTEL MUSTFIX FOR UPDATE1 -- no blocker bug !
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-11-07 16:34:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Larry Troan 2003-01-31 16:20:48 UTC
We observed that "rpm -i kernel-smp-*.rpm" stalls for a long time if there is
LS240( or normal floppy)media in the LS240 drive(not ejected). 

Our findings:
- mount a ls120/240 media; 4 partitions (hdb1,hdb2,hdb3 and hdb4) are entered in
to /proc/partitions

- umount the media but do not eject the media; /proc/partitions entries are not
removed (problem?)

- run "echo "showlabels" | /sbin/nash --force --quiet" (which is executed as a
part of new-kernel-pkg)

- This will stall the rpm installation. To customer/user, this looks like the
rpm installation is hanging. 

The workaround is to eject the media or wait for a long time.

/sbin/nash goes through all the hdb partitions in the /proc/partitions even
though the media is no longer mounted and it tooks long time to complete. This
time is shorter for normal floppies.

As a result of having hdb partitions in /proc/partitions even though the media
is unmounted, reading ext2_superblock in get_label_uuid(mount_by_label.c)
functions blocks.

The same problem occurs if you are installing the OS when there is a media in
the drive. 




----------
Action by: leventakyil
Issue Registered
----------
Action by: leventakyil


Status set to: Waiting on Tech

----------
Action by: leventakyil
The issue described above is seen on on Tiger4. But reproduced it on RH8.0, also.


----------
Action by: ltroan
Do we have LS240 hardware and media to reproduce this error? If not, can we get
some? 

How is this hardware attached to a box (USB, 1394, PCMCIA, IDE, SCSI, ...)?

ltroan assigned to issue for Intel.

Category set to: Hardware
Status set to: Waiting on Client


THIS IS ISSUE TRACKER 14700 TAKEN OUT BY INTEL AS A SEVERITY 2.

Comment 1 Michael Fulbright 2003-01-31 17:42:41 UTC
This is most likely a grubby issue.

It should filter out drives with removable media like the installer does when
autopartitioning.

Comment 2 Jeremy Katz 2003-01-31 20:45:22 UTC
No, kernel problem.  The partitions don't disappear from /proc/partitions when
the media is ejected.

Comment 3 Larry Troan 2003-02-18 03:54:00 UTC
Status?

Comment 4 Larry Troan 2003-05-19 15:01:23 UTC
PER EMAIL FORM JBARON ON 3/24/03....
On Mon, 24 Mar 2003, Larry Troan wrote:


> Jason,
> 
> Any status on this?  I assume this would be an anaconda respin and 
> therefore targeted for taroon (RJEL 3).
> 
> Please let me know so I can update Intel on this. You can put it in 
> Bugzilla if you wish or sent me an email.


hmmm...not really sure if this is a kernel bug or not...i don't think we 
fix this in the 2.1 codebase, and i'd guess it will simply disappear in in 
AS3.0, if its not an issue for later kernels...


-Jason



Comment 5 Jason Baron 2003-11-07 16:34:17 UTC
I'm changing this to resolved in current release...as there is a
workaround and i suspect this issue is resolved.