Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83200

Summary: Excessive memory allocation to screensaver followed by gnome system monitor crash
Product: [Retired] Red Hat Linux Reporter: Need Real Name <dapthar>
Component: xscreensaverAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-11-09 16:22:34 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
A screenshot of the multiple copies of GL text using huge amounts of memory none

Description Need Real Name 2003-01-31 06:23:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
My bug is similar in spirit to other gnome memory leaks that have been reported
(like the ones that come up when I search Bugzilla using the terms "gnome
memory" e.g.  # 73156) but has a few key differences.  The bug is as follows:
when I am previewing my GL Text screensaver (in the small window) and have the
gnome system monitor open, I hear my processor begin working like crazy.  I open
up the system monitor graphs to see what is going on and I see that memory is
being allocated very rapidly, and my memory usage shoots up.  The
differentiating factor between my bug and the others is that every single time
this bug occurs, it allocates about � of the available RAM (total 1006MB)  to 2
copies of the GL Text screensaver, and after which, it abruptly stops.  It
allocates roughly 100-150MB to each copy.

I initially thought that this halting was a random occurance, but every single
time this bug has occurred, it stops itself once it reaches around � of my RAM.
 These allocation events usually end up allocating around 150-200MB of my RAM
before stopping, since my normal memory usage hovers around 250-350MB when I
have open office, Mozilla, the screensaver preview, and the system monitor open.
 Shortly afterwards the system monitor crashes, and brings up the bug report
field, which I previously closed out.

Finally, while I was writing this, the bug has occurred again, but since I am
already submitting this bug report via the Bugzilla website, I closed out the
Bugzilla report window it brought up.  I will try to attach a screenshot from my
system monitor window, but since I have not submitted a bug before, I am unsure
as to how it will work out.  

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Go preferences -> screen saver (after boot up)
2. Go to preview the GL Text screensaver (the one that displays your kernel
version and hostname) 
3. Open up system monitor
4. Wait 5 minutes (it usually takes less than 5 minutes to occur)
    

Actual Results:  What happened after I performed the steps above is that my
gnome system-monitor crashed after the memory allocation.

Expected Results:  I expect the system to not allocate such huge amounts of
memory to 2 copies of the screensaver when I am simply previewing it.

Additional info:

System information:

From uname: 2.4.18-19.8.0smp #1 SMP Thu Dec 12 04:36:25 EST 2002 i686 i686 i3
86 GNU/Linux

I currently have all of the packages installed (I selected the "everything"
option during the install process), and I have the current versions of
everything from the up2date service.
I also have a GeForce 4 Ti4600 with version 1.0-3123 of the NVIDIA drivers
installed sucessfully.

On a final note, I have read all of the gnome memory bugs that have been posted,
and none of those bugs appear to be present on my system, as I have followed the
instructions to reproduce them to the letter.

Comment 1 Need Real Name 2003-01-31 06:29:25 UTC
Created attachment 89730 [details]
A screenshot of the multiple copies of GL text using huge amounts of memory

Comment 2 Bill Nottingham 2003-02-04 02:41:19 UTC
Does this happen without the NVIDIA drivers?

Comment 3 Need Real Name 2003-02-08 00:56:37 UTC
First of all, sorry for the delay.

Next, yes, I tried this without the NVIDIA drivers and using the default "vesa"
drivers, and I still get the same result.

Also, I have noticed that previewing the screensaver is not necessary for this
bug to occur, it just takes more time to occur if I just let my system idle for
a while.

Comment 4 Need Real Name 2003-03-28 04:34:37 UTC
Have there been any new developments regarding this bug?

Comment 5 Ray Strode [halfline] 2004-11-09 16:22:34 UTC
Hi,

I've spent sometime trying to reproduce this bug and was unable to do
so.  Given the age of this report and my failure to reproduce the
problem, I think it's very likely the bug has been fixed.  I'm going
to close the bug, but if you continue to have the problem with FC3 or
a recent version of xscreensaver, please feel free to reopen the bug.