Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83196

Summary: firstboot had gethostbyaddr() errors
Product: [Retired] Red Hat Linux Reporter: Miroslav Krajca <miroslav>
Component: firstbootAssignee: Brent Fox <bfox>
Status: CLOSED DUPLICATE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:51:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Miroslav Krajca 2003-01-31 04:27:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
Traceback (most recent call last): 
  File "/usr/share/firstboot/firstbootWindow.py", line 153, in __init__ 
    vbox, eventbox = module.launch() 
  File "/usr/share/firstboot/modules/date.py", line 75, in launch 
    self.setupScreen() 
  File "/usr/share/firstboot/modules/date.py", line 64, in setupScreen 
    self.datePage = date_gui.datePage(self.dateBackend) 
  File "/usr/share/redhat-config-date/date_gui.py", line 171, in __init__ 
    ntpServer = socket.gethostbyaddr(ntpServerIP)[0] 
TypeError: gethostbyaddr() argument 1 must be string, not None


Machine was booted in SMP kernel.
Type of machine:  Dual AMD Athlon MP
                  Tyan S2466-4M motherboard
                  1 gig Ram


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. this only occured during the initial install.
2.
3.
    

Additional info:

firstboot continued as normal afterwards

Comment 1 Bill Nottingham 2003-01-31 05:10:09 UTC

*** This bug has been marked as a duplicate of 82061 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:31 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.