Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83111

Summary: efence broken on Hammer
Product: [Retired] Red Hat Raw Hide Reporter: Joe Orton <jorton>
Component: ElectricFenceAssignee: Jakub Jelinek <jakub>
Status: CLOSED RAWHIDE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 1.0   
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-04 16:42:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79579    

Description Joe Orton 2003-01-30 13:40:17 UTC
Description of problem:
ElectricFence dumps core on Hammer immediately at startup.

Version-Release number of selected component (if applicable):
ElectricFence-2.2.2-14

How reproducible:
Always

Steps to Reproduce:
e.g.
$ ef ls

anything linked against -lefence does likewise, as does running the test suite
in the EF sources.

Actual results:

  Electric Fence 2.2.0 Copyright (C) 1987-1999 Bruce Perens <bruce@perens.com>
/usr/bin/ef: line 20:  1132 Segmentation fault      ( export
LD_PRELOAD=libefence.so.0.0; exec $* )


Expected results:
No segfaults.


Additional info:
EF test suite passes if not compiled with -DUSE_SEMAPHORE.
From adding debugging, the segfault occurs in exactly the pthread_self() call in
efence.c:lock().

Comment 1 Joe Orton 2003-01-30 13:57:57 UTC
(As an aside, efence.c seems to assume 0 isn't a valid pthread_t, which I don't
believe is correct, and it probably should be using pthread_equal rather than !=
to compare pthread_t values.  Neither of these seem to be the cause of the
segfaults, however.)

Comment 2 Jakub Jelinek 2003-02-04 16:42:31 UTC
Should be fixed in ElectricFence-2.2.2-15.

Comment 3 Joe Orton 2003-02-04 16:55:33 UTC
Thanks Jakub, works fine for me now.