Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83076

Summary: X server crashes
Product: [Retired] Red Hat Public Beta Reporter: Michael Wardle <michael.wardle>
Component: XFree86Assignee: Mike A. Harris <mharris>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: high Docs Contact:
Priority: medium    
Version: phoebeCC: mike
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-24 10:50:05 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 82787    
Attachments:
Description Flags
first X server log
none
second X server log
none
XFree86 server configuration file none

Description Michael Wardle 2003-01-29 23:30:43 UTC
Description of problem:
When I lock my GNOME session using the Lock Screen menu item and go away
for some time, I come back and the system is sitting at the GDM login prompt.
This suggests that the X server died.

How reproducible:
Always.

Steps to Reproduce:
1. Click on the "Lock Screen" menu item in GNOME
2. Leave the machine for some time
    
Actual results:
Get a GDM login prompt.

Expected results:
Get an Xscreensaver password prompt, then am returned to running GNOME/X session.

Additional info:
I have an i810/i815 video card and am running the "Molecule" Xscreensaver
module.  I will post additional information (X server log, etc.) soon.

Comment 1 Michael Wardle 2003-01-30 00:32:07 UTC
Created attachment 89707 [details]
first X server log

Comment 2 Michael Wardle 2003-01-30 00:33:49 UTC
Created attachment 89708 [details]
second X server log

Comment 3 Michael Wardle 2003-01-30 00:36:12 UTC
First server log is from /var/log/XFree86.0.log.old, dated from about 2 hours
ago.  This would seem to be the log from the last X server crash.

Second server log is from /var/log/XFree86.0.log, dated about 15 minutes ago.
This would seem to be the log from the current (still running) X server.


Comment 4 Michael Wardle 2003-01-30 00:39:22 UTC
An older issue that seems to be similar to this is bug 73827.

I'm running Red Hat Linux 8.0.92 (Phoebe) on an HP Vectra workstation
(Pentium III, 128 MB RAM, i815 mainboard and video).

Package versions are those from default Phoebe install:
XFree86-4.2.99.2-0.20021217.0
xscreensaver-4.06-4

I'll try changing my screensaver settings in case the bug is being
triggered by some tricky graphics (maybe OpenGL or DRI) in the
screensaver used when the screen is locked.


Comment 5 Michael Wardle 2003-01-30 00:40:40 UTC
Created attachment 89709 [details]
XFree86 server configuration file

I'm adding my X server configuration file in case it's useful.

Comment 6 Bill Nottingham 2003-01-30 05:15:25 UTC
Is there anything in /var/log/messages around the times of the crashes?

Comment 7 Michael Wardle 2003-01-30 05:23:06 UTC
Only the following, which is probably to be expected:

Jan 30 09:38:41 selene gdm[15389]: gdm_slave_xioerror_handler: Fatal X error -
Restarting :0


Comment 8 Mike Chambers 2003-02-11 03:49:32 UTC
Is this with Phoebe 1 or 2?  If 1, please install 2 and see if that fixes it.  
If not, make sure you run up2date to see if anything has been sent down, maybe 
even check rawhide packages to see if this helps fix the problem.

Comment 9 Mike A. Harris 2003-02-14 23:16:07 UTC
Does this problem still occur in the latest builds?

Please respond ASAP, because 10 day gaps between responses might mean that
if this issue is still present, that it may not get addressed or given the
attention it deserves before XFree86 4.3.0 is released.

Thanks in advance.

Comment 10 Michael Wardle 2003-02-18 02:20:03 UTC
I installed XFree86-4.2.99.901-20030213.1 and all its dependent packages
from Raw Hide today, and as yet I am unable to reproduce this problem.


Comment 11 Mike A. Harris 2003-02-24 10:50:05 UTC
Thanks for the update, closing bug as fixed in RAWHIDE.