Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83003

Summary: typo in 'import gpg key' text
Product: [Retired] Red Hat Linux Reporter: Patrick C. F. Ernzer <pcfe>
Component: up2dateAssignee: Adrian Likins <alikins>
Status: CLOSED CURRENTRELEASE QA Contact: Fanny Augustin <fmoquete>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: gafton, ivo, mihai.ibanescu
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-04-07 16:41:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79579    
Attachments:
Description Flags
/etc/sysconfig/rhn/up2date none

Description Patrick C. F. Ernzer 2003-01-29 14:08:27 UTC
Description of problem:
when up2date is run and the gpg key is not imported, we tell the user to use
'rpm --import /usr/share/rhn/RPM-GPG-KEY

Version-Release number of selected component (if applicable):
3.0.42-3

How reproducible:
always

Steps to Reproduce:
1. install system, do not use X (i.e. no first boot)
2. run 'up2date -register' from shell
3. follow instructions
    
Actual results:
using rpm --import /usr/share/rhn/RPM-GPG-KEY just returns, user gets same
'please import key' on next run of 'up2date --register'

Expected results:
text reading 'gpg --import /usr/share/rhn/RPM-GPG-KEY'

Additional info:

Comment 1 Adrian Likins 2003-01-29 19:31:14 UTC
rpm --import /usr/share/rhn/RPM-GPG-KEY 
is correct

The problem is that needs to be done as `root`. 
The text should probabaly include that as well.

Comment 2 Adrian Likins 2003-01-30 05:14:21 UTC
Actually, the exact message is:

"""Your GPG keyring does not contain the Red Hat, Inc. public key.
Without it, you will be unable to verify that packages Update Agent downloads
are securely signed by Red Hat.

Your Update Agent options specify that you want to use GPG.

To install the key, run the following as root:

    rpm --import /usr/share/rhn/RPM-GPG-KEY"""

Which is correct. 


If thats not working, something else is wrong.

Whats the output of:

rpm -q gpg-pubkey

?


Comment 3 Patrick C. F. Ernzer 2003-01-30 13:50:39 UTC
# rpm -q gpg-pubkey
gpg-pubkey-db42a60e-37ea5438
gpg-pubkey-db42a60e-37ea5438
gpg-pubkey-db42a60e-37ea5438

normal, as I've used the command 3 times.

but the system still nags at me that the key needs importing.

All steps done as root on tty1

after this I did:
Script started on Thu 30 Jan 2003 01:44:33 PM GMT
[root@lotte root]# rpm -e --allmatches gpg-pubkey
[root@lotte root]# rpm -q gpg-pubkey
package gpg-pubkey is not installed
[root@lotte root]# rpm --import /usr/share/rhn/RPM-GPG-KEY 
[root@lotte root]# rpm -q gpg-pubkey
gpg-pubkey-db42a60e-37ea5438
[root@lotte root]# up2date -l
Your GPG keyring does not contain the Red Hat, Inc. public key.
Without it, you will be unable to verify that packages Update Agent downloads
are securely signed by Red Hat.

Your Update Agent options specify that you want to use GPG.

To install the key, run the following as root:

    rpm --import /usr/share/rhn/RPM-GPG-KEY

[root@lotte root]# exit

Script done on Thu 30 Jan 2003 01:45:40 PM GMT


Comment 4 Patrick C. F. Ernzer 2003-01-30 13:53:09 UTC
Created attachment 89717 [details]
/etc/sysconfig/rhn/up2date

the up2date configuration file on the machine exhibiting the problem.

Comment 5 Adrian Likins 2003-01-31 20:11:37 UTC
oh, duh... had to stumble into this myself before it occured
to me what it is.

The message is wrong, sorta. Or at least wrong for
beta versions. It should tell you to:

rpm --import /usr/share/rhn/BETA-RPM-GPG-KEY 

as well, for the beta.


versions in the beta check for existing of the
beta key as well as the normal key. In the gui,
if you click "ok" to import the key, it actually
imports both keys. The cmdline doesn't tell you
to import the beta key.

I'll take a look at cleaning this up.

Comment 6 Adrian Likins 2003-02-07 18:09:17 UTC
*** Bug 83575 has been marked as a duplicate of this bug. ***