Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 82989

Summary: Installer fails while attempting to partition IDE drive
Product: [Retired] Red Hat Linux Reporter: Kaj J. Niemi <kajtzu>
Component: partedAssignee: Matt Wilson <msw>
Status: CLOSED CURRENTRELEASE QA Contact: Brock Organ <borgan>
Severity: high Docs Contact:
Priority: medium    
Version: 8.0CC: dcfogg, os
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-11-21 00:18:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Kickstart Configuration none

Description Kaj J. Niemi 2003-01-29 11:49:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030121

Description of problem:
Am booting off a normal RH8 CD1 for either manual or kickstart installation. 

Anaconda replies:

"The kernel was unable to re-read the partition table on /tmp/hda (device or
resource busy).  This means that Linux knows nothing about any modifications you
made.  You should reboot your computer before doing anything with /tmp/hda"

Installation pretty much ends here no matter what I do. ;-)

I'm able to reproduce this both manually and via kickstart. No weird errors are
reported anywhere.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RH8 on a clean system
2. Follow prompts, wait for partitioning
3. Attempt to partition
    

Expected Results:  Partition should be written and installation should continue.

Additional info:

Motherboard is a Intel SE7500CW2 (Clearwater) and the IDE drive is connected to
the Primary IDE bus.

There's really nothing wrong with the IDE drives since WinXP installs fine,
Win2K installs fine and FreeBSD seems to install fine.

Also if going through "linux rescue" and doing "fdisk /dev/hda" one is able to
write a new partition table without any problems.

I'll try to get the lspci -v and dmesg off the server somehow, if needed.

This seems to be similar to a problem reported in bug #64788, #82269 seems to be
similar too.

Comment 1 Kaj J. Niemi 2003-01-29 12:08:36 UTC
Failed on drive type Maxtor DiamondMax Plus 8 (40 GB), shows up as 6E040L0510211
(or 6E040L05), tried with several.

Changed to an IBM IC35L040AVVN07-0 (40 GB) and it started working.



Comment 2 Matt Wilson 2003-02-06 03:40:06 UTC
what kind of IDE hard drive did you have?


Comment 3 Matt Wilson 2003-02-06 03:40:27 UTC
*** Bug 82269 has been marked as a duplicate of this bug. ***

Comment 4 Oliver Schonefeld 2003-03-26 11:10:59 UTC
We have the same Problem here. We've already exchaged an 80GB IBM Drive
(can't remember exact model) for a 80 GB Matror Drive (Maxtor 6Y080L0
ATA-133) but still no success.
Mainboard is a MSI-9211 and the drive is currently connected as master on   
the primary ide bus.

I can create partitions with fdisk when anaconda creashed and the kernel
sees them on the next boot but even if I hardwire partitions in the         
kickstart installation (e.g. part /  --fstype=ext3 -onpart=hda1) , the installer aborts this error message.


Comment 5 Matt Wilson 2003-03-26 15:09:44 UTC
Do you get the "device or resource busy" message?

Can you attach your ks.cfg?


Comment 6 Oliver Schonefeld 2003-03-26 16:01:57 UTC
Created attachment 90725 [details]
Kickstart Configuration

some unimportant parts omitted

Comment 7 Matt Wilson 2003-03-26 16:10:08 UTC
And it falls over every time?


Comment 8 Kaj J. Niemi 2003-06-25 14:38:45 UTC
Matt,


Somehow I got one of these back (surprise, surprise!) on my table exhibiting the
problem described earlier on.. Is there anything special you want me to run on
it because now is the time if ever ;-)





Comment 9 Kaj J. Niemi 2003-08-26 17:12:25 UTC
Please feel free to close this issue, it doesn't seem to be reproducible with
the RH9 or Severn installer... lots of other fun things with the CW2
motherboards as well.



Comment 10 Kaj J. Niemi 2003-11-21 00:18:37 UTC
Resolving as CURRENTRELEASE, not happening with the FC1 installer either.