Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 82890

Summary: Install crashes unhandled exception error
Product: [Retired] Red Hat Linux Reporter: Sean <masmatrix>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED DUPLICATE QA Contact: Mike McLean <mikem>
Severity: high Docs Contact:
Priority: high    
Version: 8.0CC: masmatrix
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:51:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
unhandled exception dump error none

Description Sean 2003-01-28 06:04:49 UTC
Description of problem:After partitions are automatically done and right after 
the installation of packages begins, I get unhandled exception error and a 
prompt to dumb to disk.  This happens in both GUI and Text installs. I get the 
same error.  Here is part of the dump file:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 632, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 120, in readPackages
    id.comps = method.readComps(id.hdList)
  File "/usr/lib/anaconda/installmethod.py", line 60, in readComps
    return self.readCompsViaMethod(hdlist)
  File "/usr/lib/anaconda/image.py", line 33, in readCompsViaMethod
    return ComponentSet(fname, hdlist)
  File "/usr/lib/anaconda/comps.py", line 1013, in __init__
    self.readCompsFile(file, self.packages)
  File "/usr/lib/anaconda/comps.py", line 712, in readCompsFile
    self.compsxml = rhpl.comps.Comps(file)
  File "/usr/lib/python2.2/site-packages/rhpl/comps.py", line 297, in __init__
    self.load (filename)
  File "/usr/lib/python2.2/site-packages/rhpl/comps.py", line 304, in load
    doc = libxml2.parseMemory(file, len(file))
  File "/usr/lib/python2.2/site-packages/libxml2.py", line 717, in parseMemory
    if ret == None:raise parserError('xmlParseMemory() failed')
parserError: xmlParseMemory() failed

Local variables in innermost frame:
buffer: <?xml version="1.0"?>
<!DOCTYPE comps PUBLIC "-//Red Hat, Inc.//DTD Comps info//EN" "comps.dtd">

<comps>
<!--  <meta> -->
<!-- Meta information will go here eventually -->
<!--  </meta> -->
  <group>
    <id>core</id>
    <name>Core</name>
    <name xml:lang="cs">Jádro</name>
    <name 


Version-Release number of selected component (if applicable):


How reproducible:Everytime


Steps to Reproduce:
1.Server install/default
2.eth0 set to trusted/ftp and dhcp allowed in firewall set up
3.3-button ps/2 mouse
    
Actual results:unhandled exception error


Expected results:


Additional info:system is AMD k6/2 500mhz, tnt2 m64, compaq 10/100 ether, clean 
maxtor 5.7gb, cd-rom,256mb ram

Comment 1 Sean 2003-01-28 06:12:58 UTC
To add to this/correction.  The exception error is happening after I click 'ok' 
on the root password screen after putting in the password/while reading 
packages to be installed.

Comment 2 Jeremy Katz 2003-01-29 21:43:38 UTC
What type of installation is this?  Could you attach the full traceback you receive?

Comment 3 Sean 2003-01-29 23:06:50 UTC
Created attachment 89705 [details]
unhandled exception dump error

Comment 4 Sean 2003-01-29 23:08:04 UTC
all the installations do this.  Text and gui.  everytime i try the install no 
matter how i do it.  i even took out my scsi devices thinking that was the 
problem.

Comment 5 Michael Fulbright 2003-01-30 20:11:13 UTC
These errors in the log:

<4>end_request: I/O error, dev 16:00 (hdc), sector 1105284
<4>hdc: command error: status=0x51 { DriveReady SeekComplete Error }
<4>hdc: command error: error=0x54
<4>end_request: I/O error, dev 16:00 (hdc), sector 1105284

indicate this is caused by a bad red from the CD.




*** This bug has been marked as a duplicate of 75008 ***

Comment 6 Red Hat Bugzilla 2006-02-21 18:51:27 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.