Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 82603

Summary: NFS Clients hang forever when trying to reboot them while an nfs server is down.
Product: [Retired] Red Hat Linux Reporter: Glen <glen>
Component: nfs-utilsAssignee: Steve Dickson <steved>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-06-15 21:20:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Glen 2003-01-23 22:22:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
If one of our nfs servers goes down and while it is down we try and reboot one
of the nfs clients, then the client will hang forever when it tries to unmount
the nfs drives.  Actually, I guess I can't say forever, but I've waited many
many hours for something to time out but I'm always forced to just reset the
systems.  None of this happened until we started using the hard mount option. 
But we can't use the soft mount option because with soft mounts the jobs we run
on our various servers are more likely to crash.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Set up an nfs client and server with the hard mount option.
2.Shut down the server.
3.Try and reboot the client.
    

Actual Results:  The client will hang when it tries to unmount the nfs drives.

Expected Results:  The client will hang when it tries to unmount the nfs drives.

Additional info:

Comment 1 Glen 2003-03-06 20:37:02 UTC
I installed the new 2.4.18-24 kernel on all my machines and that fixed this problem.