Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 82600

Summary: squirrelmail-1.2.10-2 has syntax error in download.php
Product: [Retired] Red Hat Public Beta Reporter: d. johnson <drjohnson1>
Component: squirrelmailAssignee: Gary Benson <gbenson>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: phoebeCC: bugzilla.redhat.com, dyeager, havard, markku.arvekari, mcampbell, p.van.egdom
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-10 15:01:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79578    

Description d. johnson 2003-01-23 22:10:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030119

Description of problem:
line 337 of /usr/share/squirrelmail/src/download.php is missing a matched set of
parens.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Load SM in your browser
2. Attempt to download anything
3. Profit!
    

Actual Results:  Error result because of missing paren.

Expected Results:  You should be able to download the file.

Additional info:

Either snag a newer CVS snap, or add the paren.

Comment 1 Gary Benson 2003-02-10 15:01:01 UTC
Fixed as of 1.2.10-4.

Comment 2 Gary Benson 2003-03-06 09:54:27 UTC
*** Bug 85689 has been marked as a duplicate of this bug. ***

Comment 3 HÃ¥vard Hiller 2003-03-06 13:36:08 UTC
The same bug excists in version 1.2.11

Comment 4 Gary Benson 2003-03-06 14:03:35 UTC
The bug does not exist in 1.2.10-4, which is in Rawhide at this present moment
in time.

Comment 5 Gary Benson 2003-03-06 16:14:53 UTC
*** Bug 85724 has been marked as a duplicate of this bug. ***

Comment 6 Gerald Teschl 2003-03-07 09:27:13 UTC
I feel you shoud issue another errata.

BTW, for those looking for a quick fix:
--- download.php.orig   Fri Mar  7 10:20:35 2003
+++ download.php        Fri Mar  7 10:20:43 2003
@@ -334,7 +334,7 @@
         $suffix = $type1;
     }

-    $filename = 'untitled' . strip_tags($passed_ent_id) .$suffix);
+    $filename = 'untitled' . strip_tags($passed_ent_id) .$suffix;
 }


Comment 7 Gary Benson 2003-03-10 09:41:18 UTC
*** Bug 85860 has been marked as a duplicate of this bug. ***

Comment 8 Gary Benson 2003-03-12 09:52:28 UTC
*** Bug 86009 has been marked as a duplicate of this bug. ***