Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 82505

Summary: glibc-2.3.1-38 kills vmware 3.2
Product: [Retired] Red Hat Raw Hide Reporter: bzrh
Component: glibcAssignee: Jakub Jelinek <jakub>
Status: CLOSED NOTABUG QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: fweimer, michael
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-23 18:51:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description bzrh 2003-01-22 22:12:14 UTC
Description of problem:
VMWare bombs out with:

XIO:  fatal IO error 0 (Success) on X server ":0.0"
      after 2831 requests (2830 known processed) with 99 events remaining.

right after launch (while drawing UI).  This started right after I updated from rh8.0 stock glibc to 2.3.1-38 out of rawhide.

Version-Release number of selected component (if applicable):
glibc-2.3.1-38
VMwareWorkstation-3.2.0-2230

How reproducible:
100% reproducible.

Steps to Reproduce:
1./usr/bin/vmware
2.boom!
3.
    
Actual results:
vmware exits

Expected results:
vmware works

Additional info:

Comment 1 Michael Lee Yohe 2003-01-23 14:11:25 UTC
Resolution == DUPLICATE (Bug 82551)

Mike Harris opened Bug 82551 - Red Hat does not official support VMWare's
virtual environment as an actual x86 environment.  Any problems with VMWare
should be handled by VMWare itself, not necessarily Red Hat as they have no
ability to peer into the source code where VMWare breaks.

Comment 2 bzrh 2003-01-23 16:56:43 UTC
I don't believe the assignment as a duplicate of 82551 is appropriate.  The bug I reported is NOT of redhat running INSIDE vmware; rather, it is of VMWare running (and crashing) inside a native redhat host.  

As the "closing remarks" of 82551 note, RH tries, where possible, to make vmware be happy with rh, though not officially.  I would like to see this resolved under that clause :)

Thanks.


Comment 3 Michael Lee Yohe 2003-01-23 17:59:39 UTC
Fair enough - but nonetheless, VMWare should be made aware that the new version
of glibc that will be included with Red Hat Linux 8.1 will break their software.
 There was another glibc related bug and the only solution was "please wait
until glibc itself is considered stable - the rawhide release can and will
produce inconsistencies with software built with older versions of glibc".

Comment 4 bzrh 2003-01-23 18:51:23 UTC
Touche.  

vmware should be aware of this fact now.  Apparently the problem is that the vmware binary includes a couple of object files from libc 2.1.3 (!!!), and the new errno handling conflicts (obviously) with this.  Closing this bug, since it doesn't seem to be anything that redhat can do anything about.

FWIW, for posterity, Petr Vandrovec reports that LD_PRELOAD'ing the ld-2.3.1.so from rawhide's glibc-2.3.1-16 rpm makes vmware work again.  I haven't tried this yet (still trying to find a copy of that RPM).

Cheers.