Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 82499

Summary: Firstboot is started in runlevel 3?
Product: [Retired] Red Hat Linux Reporter: Bernd Bartmann <bernd.bartmann>
Component: firstbootAssignee: Brent Fox <bfox>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: mitr
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-05-25 14:30:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Bernd Bartmann 2003-01-22 21:17:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I just installed Phoebe2 on my notebook and configured it to come up in text
mode (runlevel 3).On the first boot I noticed that the system tries to start
firstboot. "Starting firstboot: " stays there for at least 1 minute and then I
get my login prompt. It even creates /etc/sysconfig/firstboot containing
RUN_FIRSTBOOT=no. Is this really the intended behaviour for runlevel 3?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Installe Phoebe2 and configure it to come up in text mode (runlevel 3)
2. Watch the firstboot message during system startup
3.
    

Additional info:

Comment 1 Brent Fox 2003-01-25 02:15:58 UTC
No, it's supposed to pop up a text-based dialog asking if you want firstboot to
run or not.  Something is wrong in the initscript because the chars are being
sent to /var/log/messages instead of starting the tui interface.  I'm trying to
sort it out.

Comment 2 Brent Fox 2003-01-31 20:58:27 UTC
I've run out of time to fix this properly.  I've changed firstboot so that if it
detects that the machine is booting into runlevel 3, it assumes that you don't
want to see firstboot at all, so it writes the /etc/sysconfig/firstboot file and
disables the initscript with chkconfig so that firstboot is never run.  Should
be implemented in firstboot-1.0.5-1.

Comment 3 Brent Fox 2003-05-25 14:30:21 UTC
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.