Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 82425

Summary: Starting Abiword in Phoebe2 - splash screen, but no window
Product: [Retired] Red Hat Public Beta Reporter: Gerry Tool <gerry>
Component: abiwordAssignee: Jeremy Katz <katzj>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: phoebeCC: herrold
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-10 20:59:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 79578    

Description Gerry Tool 2003-01-22 01:03:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
I try to start Abiword and the splash screen appears, but no window ever
shows up after the splash screen goes away.  Same behaviour from the
menu or from the command line.  No errors in the terminal window.

The processes were still alive.  After moving to
Gnome to test it and back to KDE, windows appeared with the message

Abiword could not find any local font files in its font path. ....

The current font path contains the following directories:
[/home/gerry/fonts]

Doesn't seem like the place it should look for fonts.

Version-Release number of selected component (if applicable):
abiword-1.0.3-2

How reproducible:
Always

Steps to Reproduce:
1.Execute Abiword from the menu or from a terminal
2.
3.
    

Actual Results:  The splash screen appears, but no window ever
shows up after the splash screen goes away. 

Much later, a dialog window appeared with the message

Abiword could not find any local font files in its font path. ....

The current font path contains the following directories:
[/home/gerry/fonts]

Doesn't seem like a good place for it to look for fonts.

Expected Results:  Abiword should open an edit window ready for typing in a
document.

Additional info:

Comment 1 Charles R. Tersteeg 2003-01-22 04:29:56 UTC
i thought this was my case also but abiword was running just fine except it was
hiding.

when launching the app, it sizes the window to a full screen size and places the
upper right edge into the lower left corner just so you can see the "x" to close
it.  hard to see but it's there.  now how do you fix this?

Comment 2 Gerry Tool 2003-01-22 14:32:22 UTC
As pointed out by a phoebe-list member, if you specify a geometry, the window
opens normally, i.e., 

abiword -geometry 1024x768+10+10 &

from the command line opens the app.  I think the font error message might have
been an artifact of having processes running where I couldn't see the windows
when I logged out and back in.

The config should be fixed.

Comment 3 R P Herrold 2003-01-22 22:26:37 UTC
This alternative assessment crossed Phoebe list as well;:

This is quite an old issue, with an old fix.

In /etc/X11/XF86Config
you need to add a line
load Type1 in the fonts section.

does the %post presently check and do this if needed?

Comment 4 Gerry Tool 2003-01-23 01:09:36 UTC
Comment #3 above does not pertain to this report.  My XF86Config Modules section
does contain Load "Type1".  As I indicated in comment #2, the font error message
was an artifact of how I logged out, etc.  The real problem is one with
configuration of where the window is drawn at startup.

Comment 5 Jeremy Katz 2003-01-23 03:42:13 UTC
I can't reproduce this here -- is this only happening in KDE?

Comment 6 Gerry Tool 2003-01-23 04:05:14 UTC
Yes, I just logged out of KDE where it happens and tried opening Abiword in Gnome.  It opened 
just fine there from the menu with the window properly displayed. 

Comment 7 Kjartan Maraas 2003-01-31 15:13:33 UTC
I see the window being placed in the lower left corner here with the current
beta + rawhide packages and I'm using GNOME as the default desktop.

Comment 8 Jeremy Katz 2003-02-10 20:59:45 UTC
Should be fixed in 1.0.4-2