Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 82408

Summary: can't kickstart install with root in exisitng volgroup
Product: [Retired] Red Hat Public Beta Reporter: Alexandre Oliva <aoliva>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: phoebe   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-17 21:31:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 74357    
Bug Blocks: 79579    

Description Alexandre Oliva 2003-01-21 21:31:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
Anacond generates a kickstart file with a volgroup line that, if put in, will
clear the entire contents of the volume group, but if left out, will prevent me
from assigning mount points to logical volumes I intend to preserve or format.

Even more interesting: on an interactive kickstart install, if I leave the root
filesystem out of the kickstart file because I want to put it in a preserved
volume group, the installer won't let me get to the disk druid screen.  When I
click on Next in the Mouse Configuration screen, it opens a window saying that
errors have occurred with my partitioning, because I have not defined a root
partition, but when I click Ok, it remains in the Mouse Configuration screen, so
I can't fix the problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create a kickstart file setting only /boot and swap.  Enable the `interactive'
option.
2.Boot the installer with this kickstart file
3.Try to get to the Disk Druid screen
    

Actual Results:  You can't

Expected Results:  You should.

Additional info:

Comment 1 Alexandre Oliva 2003-01-21 21:37:10 UTC
And what was already more interesting got further interesting yet: if I leave
out all partitioning-related options, it will just say it couldn't make a
primary partition and give me `Reboot' as the only option.  :-(  No kickstart
for me :-(

Comment 2 Jeremy Katz 2003-02-11 03:35:56 UTC
You should be able to do this now (tested locally).  See bug 82406 for the gory
details.

Comment 3 Alexandre Oliva 2003-02-17 21:31:48 UTC
Confirmed, it works.