Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 82404

Summary: booting from cd wtih `linux ks' doesn't get ks file from dhcp server
Product: [Retired] Red Hat Public Beta Reporter: Alexandre Oliva <aoliva>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: phoebeCC: chris.ricker
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-17 21:38:05 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79579    

Description Alexandre Oliva 2003-01-21 21:06:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
Contrary to the docs in the customization guide, booting with `linux ks' doesn't
contact the dhcp server, at least when booting off the installation cd.  In VT3,
I find the message:

* grabbing kickstart from nfs with dhcp next-server currently unsupported

but this is certainly a glitch, since I have only one dhcp server active in this
network, and it definitely doesn't have the next-server option set.  Besides, it
was not contacted at all from the boot to the appearance of the message.

Adding `askmethod' to the boot line doesn't help.  Trying at random `ks=nfs'
changes the message to `reading kickstart file', regardless of the presence of
askmethod or not, but it just hangs there, without having ever contacted the
dhcp server.

`ks=nfs:' works as far as setting up networking goes, but it doesn't grab
information from dhcp as I had hoped it might.  `ks=dhcp:' (desperate try! :-)
hangs just like `ks=nfs' .

The solution was to boot `linux ks=nfs:server:/pathname', which is sub-optimal.

Version-Release number of selected component (if applicable):
phoebe2

How reproducible:
Always

Steps to Reproduce:
1.Use a dhcp server that had been used for kickstart installs of up to RHL7.3
2.boot off the cd with linux ks

    

Actual Results:  it doesn't bring up the network interface to obtain dhcp ks
information

Expected Results:  according to the docs, it should

Additional info:

Comment 3 Jeremy Katz 2003-01-23 22:25:05 UTC
It's back in CVS

Comment 4 Jeremy Katz 2003-01-30 19:55:59 UTC
*** Bug 83149 has been marked as a duplicate of this bug. ***

Comment 5 Alexandre Oliva 2003-02-17 21:38:05 UTC
Confirmed fixed in current tree.