Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 8236

Summary: rgrep -rl wm /proc/* as root crashes machine
Product: [Retired] Red Hat Linux Reporter: Mark Wormgoor <riddles>
Component: kernelAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED NOTABUG QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-06 06:23:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mark Wormgoor 2000-01-06 18:18:10 UTC
Hi,

Don't know if it's a bug, but Linux shouldn't hang without at least a
panic, so here's a short report:
rgrep -rl wm /proc/* crashes the machine
I discovered this by accident by running rgrep -rl wm .* in /root.
Machine has Redhat 6.1 installed with most patches installed.
K6-200, 64MB, 4GB harddisk

Kind regards,

           Mark Wormgoor

Comment 1 Bernhard Rosenkraenzer 2000-01-07 11:56:59 UTC
Doesn't happen with normal grep - reassigning

Comment 2 Bill Nottingham 2000-01-07 16:37:59 UTC
Are you sure it's hanging the machine?  It will certainly
hang the rgrep process, as it will try to read from things
(like /proc/kmsg) that it won't get EOF on.

Comment 3 Mark Wormgoor 2000-01-07 20:00:59 UTC
No, I'm sure it hangs the machine....
But, I finallly managed to trace the right file.
Even grep manages to crash the  machine.  Here's what happens:
grep test /proc/bus/pci/00/07.3 hangs the machine:
  1. Can't change consoles anymore
  2. CTRL+C/Z does nothing
  3. Can't ping the machine anymore (!)
Now, the device info from /proc/pci:
Bus  0, device  7, function  3:
  Bridge: Intel 82371AB PIIX4 ACPI (rev 1).
    Medium devsel. Fast back-to-back capable.
Don't know if this happens on other machines as well, but shouldn't happen.
The mainboard is an AOpen AP5T.  But it has the Intel chipset.
It's running on a K6-200Mhz.

Don't know if this is a real bug, or how many mainboards have that chipset.
Perhaps this belongs on the kernel dev list.

Comment 4 Bill Nottingham 2000-01-07 20:06:59 UTC
OK. Reassigning to kernel, as that's where the problem lies.

However, it might just be that reading the ACPI device's config
space locks it up. Out of curiousity, does it also
crash if you do 'lspci -xxx'?

Comment 5 Mark Wormgoor 2000-01-07 20:43:59 UTC
'lspci -vvx' works like a charm
but 'lspci -xxx' does crash the machine....
It says in the manpage that that's exactly what it does on some machines...
But still, should reading from the file in /proc/bus/pci/ cause this behaviour?

Comment 6 Bill Nottingham 2000-02-06 06:23:59 UTC
Yes, because it's doing the same thing as lspci -xxx.
Unfortunately, there's not much we can do, as this seems
to fall into the cases mentioned in the lspci manpage
(buggy hardware.)