Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 82329

Summary: kernel hangs while loading megaraid driver
Product: [Retired] Red Hat Linux Reporter: Pavel Urban <fc-bugzilla>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED WONTFIX QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-06-08 16:23:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
dmesg from successful boot none

Description Pavel Urban 2003-01-21 11:58:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.2) Gecko/20021216

Description of problem:
While booting kernel made from kernel-source rpm, it hangs after

megaraid: v1.18d (Release Date: Wed Aug  7 18:51:51 EDT 2002)
megaraid: found 0x101e:0x1960:idx 0:bus 5:slot 0:func 0
scsi2 : Found a MegaRAID controller at 0xf88b2000, IRQ: 21
scsi2 : Enabling 64 bit support 

This only happens when megaraid (and whole SCSI support) is compiled as
built-in. When I try it 'redhat way', ie compile it as module and boot via
initrd, everything goes ok.

My hw is:
Dell PowerEdge 6600, 4xXeon/2GHz, 16GB RAM, PERC with 8 disks in RAID 0+1
(mirrored stripe), QLA 2200 for external disk array (not used right now), AIC
7892 (dtto). Kernel is compiled from kernel-source-2.4.18-19.7.x.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Build kernel on described platform with megaraid and scsi support built-in
2.Reboot
3.
    

Additional info:

Comment 1 Pavel Urban 2003-01-21 12:01:13 UTC
Created attachment 89458 [details]
dmesg from successful boot

This is /var/log/dmesg from kernel created with scsi supoport and megaraid as
modules; boot via initrd.

Comment 2 Alan Cox 2003-06-08 16:23:04 UTC
No idea. Closing because we don't deal with bugs in customer built kernels and
we don't have any ideas what is up either.