Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 823175

Summary: wso2-wsf-cpp : Conflicts with axis2c
Product: [Fedora] Fedora Reporter: Michael Schwendt <bugs.michael>
Component: axis2cAssignee: Garrett Holmstrom <gholms>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: gholms, matt, pmackinn, rrati
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-02 20:29:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Michael Schwendt 2012-05-19 18:28:45 UTC
=> wso2-wsf-cpp-2.1.0-7.fc18.src.rpm
=> wso2-axis2-http-server-2.1.0-7.fc18.i686 in fedora-development-i386
  File conflict with: axis2c-1.6.0-4.fc17.i686
     /usr/bin/axis2_http_server

[semi-automated bug report]

Comment 1 Michael Schwendt 2012-05-19 18:31:10 UTC
=> wso2-wsf-cpp-2.1.0-7.fc18.src.rpm
=> wso2-axis2-2.1.0-7.fc18.i686 in fedora-development-i386
  File conflict with: axis2c-1.6.0-4.fc17.i686
     /usr/lib/libaxis2_http_common.so.0.6.0
     /usr/lib/libaxis2_http_receiver.so.0.6.0
     /usr/lib/libaxis2_http_sender.so.0.6.0
     /usr/lib/libguththila.so.0.6.0

=> wso2-wsf-cpp-2.1.0-7.fc18.src.rpm
=> wso2-axis2-devel-2.1.0-7.fc18.i686 in fedora-development-i386
  File conflict with: axis2c-devel-1.6.0-4.fc17.i686
     /usr/include/axis2-1.6.0/axiom_util.h
     /usr/include/axis2-1.6.0/axis2_callback.h
     /usr/include/axis2-1.6.0/axis2_const.h
     /usr/include/axis2-1.6.0/axis2_http_header.h
     /usr/include/axis2-1.6.0/axis2_http_request_line.h
     /usr/include/axis2-1.6.0/axis2_http_server.h
     /usr/include/axis2-1.6.0/axis2_http_status_line.h
     /usr/include/axis2-1.6.0/axis2_http_svr_thread.h
     /usr/include/axis2-1.6.0/axis2_op_client.h
     /usr/include/axis2-1.6.0/axis2_simple_http_svr_conn.h
     /usr/include/axis2-1.6.0/axis2_svc_client.h
     /usr/include/axis2-1.6.0/axis2_transport_receiver.h
     /usr/include/axis2-1.6.0/axutil_allocator.h
     /usr/include/axis2-1.6.0/axutil_array_list.h
     /usr/include/axis2-1.6.0/axutil_log.h
     /usr/include/axis2-1.6.0/axutil_stream.h
     /usr/include/axis2-1.6.0/config.h
     /usr/include/axis2-1.6.0/guththila_buffer.h
     /usr/include/axis2-1.6.0/platforms/unix/axutil_unix.h
     /usr/lib/pkgconfig/axis2c.pc

Comment 2 Pete MacKinnon 2012-05-21 15:39:57 UTC
wso2-wsf-cpp is actually the incumbent in this case. Perhaps the axis2c package maintainer could contact us regarding consolidation?

Comment 3 Garrett Holmstrom 2012-05-22 01:09:07 UTC
*** Bug 823177 has been marked as a duplicate of this bug. ***

Comment 4 Garrett Holmstrom 2012-05-22 01:28:05 UTC
(In reply to comment #2)
> wso2-wsf-cpp is actually the incumbent in this case. Perhaps the axis2c
> package maintainer could contact us regarding consolidation?

WSO2 upstream bundles libs, eh?  I suppose it makes sense; the old axis2c upstream is long since dead.  How about I compare the sources and report back so we can come up with a plan after that?

Comment 5 Pete MacKinnon 2012-05-22 02:47:15 UTC
Yeah, I think we need to figure out the union of the patches from each. Ours have been posted upstream also. condor-aviary package is our actual user of the wso2-wsf-cpp runtime, but we packaged everything (devel, rampart, etc.) since wso2 folds in the 1.6.0 src tree in its bundle.

Comment 6 Garrett Holmstrom 2012-06-07 18:02:13 UTC
% diff -rup -x configure -x '*sample*' -x '*test*' -x '*.git*' -x '*docs*' -x patches -x '.pc' ~/src/axis2c-src-1.6.0 ~/rpmbuild/SOURCES/wso2-wsf-cpp-src-2.1.0/wsf_c/axis2c | diffstat -s
 437 files changed, 28825 insertions(+), 32724 deletions(-)

Ouch.

The patchset I currently have fixes one CVE and attempts to plug a few memory leaks.  If those fixes aren't already in WSF's code then we can probably look into adding them.

Right now the only actively-developed program I can think of with a hard dependency on the original axis2c/rampartc is Eucalyptus, so I filed a bug there to see if that can be made to work with WSF's code instead.

https://eucalyptus.atlassian.net/browse/EUCA-2263

Comment 7 Garrett Holmstrom 2012-08-02 20:29:01 UTC
Eucalyptus seems to be on the way to porting to wso2-wsf-axis2, so I simply removed the non-wso2 version of axis2c from rawhide.  If any patches need porting we can do that in separate bugs.

Thanks!