Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 82255

Summary: kernel-2.4.20-2.21 fsck problem
Product: [Retired] Red Hat Raw Hide Reporter: Sammy <umar>
Component: kernelAssignee: Dave Jones <davej>
Status: CLOSED WONTFIX QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: pfrields
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-10-30 03:22:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 79579, 100644    

Description Sammy 2003-01-20 16:11:07 UTC
While booting with kernel 2.4.20-2.21 one of my disks needed fsck since 
it was mounted 20 times already. The checking went for 1/2 hour for only 
40%. I rebooted and tried again, same story. I rebooted with 2.18, the 
check was completed in a minute.

Comment 1 Bill Nottingham 2003-01-20 22:02:30 UTC
What sort of disk and controller?

Comment 2 Sammy 2003-01-21 14:55:11 UTC
02:08.0 SCSI storage controller: Adaptec AIC-7892A U160/m (rev 02) 
 
scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.8 
        <Adaptec 29160N Ultra160 SCSI adapter> 
        aic7892: Ultra160 Wide Channel A, SCSI Id=7, 32/253 SCBs 
 
blk: queue c467a614, I/O limit 4095Mb (mask 0xffffffff) 
  Vendor: SEAGATE   Model: ST318451LW        Rev: 0003 
  Type:   Direct-Access                      ANSI SCSI revision: 03 
blk: queue c467aa14, I/O limit 4095Mb (mask 0xffffffff) 
  Vendor: SEAGATE   Model: ST318451LW        Rev: 0003 
  Type:   Direct-Access                      ANSI SCSI revision: 03 
blk: queue c467ae14, I/O limit 4095Mb (mask 0xffffffff) 
scsi0:A:0:0: Tagged Queuing enabled.  Depth 253 
scsi0:A:1:0: Tagged Queuing enabled.  Depth 253 
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0 
Attached scsi disk sdb at scsi0, channel 0, id 1, lun 0 
(scsi0:A:0): 160.000MB/s transfers (80.000MHz DT, offset 63, 16bit) 
SCSI device sda: 35566478 512-byte hdwr sectors (18210 MB) 
Partition check: 
 sda: sda1 sda2 sda3 < sda5 sda6 sda7 > 
(scsi0:A:1): 160.000MB/s transfers (80.000MHz DT, offset 63, 16bit) 
SCSI device sdb: 35566478 512-byte hdwr sectors (18210 MB) 
 sdb: sdb1