Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 82230

Summary: %packages --resolvedeps broken
Product: Red Hat Enterprise Linux 2.1 Reporter: Patrick C. F. Ernzer <pcfe>
Component: rhl-ig-as-x86Assignee: Tammy Fox <tammy.c.fox>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: low Docs Contact:
Priority: medium    
Version: 2.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-22 17:57:34 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Patrick C. F. Ernzer 2003-01-20 05:18:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
while '%packages --resolvedeps' is not in The Official Red Hat Linux 7.2
Customization Guide that is included in the AS2.1 docs CD, the file sample.ks of
that CD contains 

[start]
### Automatically resolve dependences
#%packages --resolvedeps
[end]

using the option makes anaconda crash with signal 11.

If the option is not to be used (as it is absent from the docs), please file as
a documentation bug so that the sample kickstart file reflects the
distribution's abilities.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. use --resolvedeps
2. have amanda-client in %packages section
3. do not have amanda in %packages section
    

Actual Results:  anaconda crashes with signal 11

Expected Results:  resolution of dependency

Additional info:

here's what I used:
#%packages
### Automatically resolve dependences
%packages --resolvedeps
### Ignore unresolved dependencies
#%packages --ignoredeps
python
@ GNOME
@ Network Support
mutt
links
gkrellm
amanda-client
mgetty
@ NFS File Server
@ Windows File Server
@ SQL Database Server
@ Web Server
@ DNS Name Server
@ Network Managed Workstation
@ Authoring and Publishing
@ Utilities
@ Legacy Application Support
@ Software Development
@ Kernel Development
@ Windows Compatibility / Interoperability
@ Advanced Server

Comment 1 Jeremy Katz 2003-01-21 17:54:35 UTC
--resolvedeps wasn't added as a supported option until Red Hat Linux 7.3.  Where
is the sample ks.cfg that you're looking at?

Comment 2 Patrick C. F. Ernzer 2003-01-22 13:48:46 UTC
"the file sample.ks of that CD contains"

where 'that CD' is the AS 2.1 documentation CD.

So this is a docs bug.

Comment 3 Mike McLean 2003-01-22 16:13:17 UTC
This bug has been inappropriately marked MODIFIED. Please review the bug life
cycle information at
http://bugzilla.redhat.com/bugzilla/bug_status.cgi
 
Changing bug status to ASSIGNED.


Comment 4 Jeremy Katz 2003-01-22 16:48:45 UTC
(not really the IG, but that's the only docs component for AS)
Tammy -- did this just get pulled in somehow as a process skew as the pensacola
and hampton cds were being generated at the same time?

Comment 5 Tammy Fox 2003-01-22 17:57:09 UTC
Yep. At first the sampleks CVS module only contained one file that
was exported from CVS when the Docs CD was built. I have since changed
it to have a dir per product so it doesn't happen again. The translated
Docs CDs for AS are correct FWIW because they were made after I fixed
the module.

It is fixed for future releases in CVS so I am closing out the bug.