Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 82182

Summary: won't sync with Sony Clie N610C
Product: [Retired] Red Hat Linux Reporter: Tammy Fox <tammy.c.fox>
Component: evolutionAssignee: Jeremy Katz <katzj>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-09-05 04:39:07 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tammy Fox 2003-01-19 05:18:43 UTC
After setting up the device with Tools => Pilot Settings with the Backup conduit
enabled, closing Evolution, and opening Evolution again, I select Tools => Pilot
Settings again. I see
the following:

Message: Pilot name -> clie
Message: Pilot id   -> 501
Message: Pilot username -> tfox
Message: Pilot creation/rom = 0/0
Message: Pilot sync_action -> not_set
Message: Cradle Type -> USB
Message: cradle device name -> USB
Message: cradle device name -> /dev/ttyUSB1
Message: Pilot Speed  -> 115200
Message: Timeout -> 15
gpilotd-Message: Initing gnome vfs
gpilotd-Message: gnome-pilot 0.1.71 starting...
gpilotd-Message: compiled for pilot-link version 0.11.5
gpilotd-Message: compiled with [VFS] [USB] [IrDA] [Network]
gpilotd-Message: Activating CORBA server
Message: pilot = clie
gpilotd-Message: Watching USB (/dev/ttyUSB1)
gpilotd-Message: gpilotd: Client seems ok
gpilotd-Message: gpilotd: Client seems ok
gpilotd-Message: gpilotd: monitor_on(pilot_name="clie",client_id =
IOR:010000001b000000...)
gpilotd-Message: gpilotd: corba:
notify_on(event_type=CONNECT,callback=IOR:010000001b000000...)
gpilotd-Message: gpilotd: corba:
notify_on(event_type=DISCONNECT,callback=IOR:010000001b000000...)
Message: Pilot name -> clie
Message: Pilot id   -> 501
Message: Pilot username -> tfox
Message: Pilot creation/rom = 0/0
Message: Pilot sync_action -> not_set
Message: Cradle Type -> USB
Message: cradle device name -> USB
Message: cradle device name -> /dev/ttyUSB1
Message: Pilot Speed  -> 115200
Message: Timeout -> 15

ps auxw | grep gpilot shows:

tfox     13077  0.1  2.5 14092 6480 ?        S    00:11   0:00
/usr/bin/gpilotd-control-applet
tfox     13083  0.1  1.7 13076 4460 ?        S    00:11   0:00 gpilotd
--activate-goad-server gpilotd --goad-fd 13
tfox     14138  0.0  0.2  3524  632 pts/7    S    00:13   0:00 grep gpilot

I own the /dev/ttyUSB1 device (configured in /etc/security/console.perms:
crw-------    1 tfox     uucp     188,   1 Jan  8 16:59 /dev/ttyUSB1

However, after all this, I press the HotSync button, and it eventually
times out, not syncing anything.

Comment 1 Tammy Fox 2003-01-19 05:36:36 UTC
OK, if I go back to the Conduits and enable/disable/enable one of them,
Apply, press the HotSync, then click OK, it works. It seems to be 
restarting gpilotd to fix something, but I should be able to sync
without having to enable/disable/enable a Conduit each time.

Comment 2 Jeremy Katz 2003-01-23 04:16:49 UTC
If you run gpilotd from a terminal, do you see anything when you hit the hotsync
button?  Also, is there output in dmesg about the connect of the device?

Comment 3 Tammy Fox 2003-01-28 03:00:39 UTC
If I start the daemon from the command line, I get:

gpilotd-Message: gnome-pilot 0.1.71 starting...
gpilotd-Message: compiled for pilot-link version 0.11.5
gpilotd-Message: compiled with [VFS] [USB] [IrDA] [Network]
gpilotd-Message: Activating CORBA server
gpilotd-Message: Watching USB (/dev/ttyUSB1)

After pressing the HotSync button, I get:

gpilotd-Message: setting PILOTRATE=115200
 
gpilotd-WARNING **: Unable to bind to pilot

I don't see anything specifically about the pilot in dmesg, but 
/var/log/messages has:

Jan 27 21:46:41 goofy gnome-name-server[12168]: starting
Jan 27 21:46:41 goofy gnome-name-server[12168]: name server starting
Jan 27 21:46:47 goofy kernel: hub.c: new USB device 00:1d.0-1, assigned address 3
Jan 27 21:46:47 goofy kernel: usb.c: USB device 3 (vend/prod 0x54c/0x66) is not
claimed by any active driver.
Jan 27 21:46:49 goofy modprobe: modprobe: Can't locate module char-major-188
Jan 27 21:46:50 goofy /etc/hotplug/usb.agent: Setup visor for USB product 54c/66/100
Jan 27 21:46:50 goofy kernel: usb.c: registered new driver serial
Jan 27 21:46:50 goofy kernel: usbserial.c: USB Serial support registered for Generic
Jan 27 21:46:50 goofy kernel: usbserial.c: USB Serial Driver core v1.4
Jan 27 21:46:50 goofy kernel: usbserial.c: USB Serial support registered for
Handspring Visor / Palm 4.0 / Clié 4.x
Jan 27 21:46:50 goofy kernel: usbserial.c: Handspring Visor / Palm 4.0 / Clié
4.x converter detected
Jan 27 21:46:50 goofy kernel: visor.c: Handspring Visor / Palm 4.0 / Clié 4.x:
Number of ports: 2
Jan 27 21:46:50 goofy kernel: visor.c: Handspring Visor / Palm 4.0 / Clié 4.x:
port 1, is for Generic use and is bound to ttyUSB0
Jan 27 21:46:50 goofy kernel: visor.c: Handspring Visor / Palm 4.0 / Clié 4.x:
port 2, is for HotSync use and is bound to ttyUSB1
Jan 27 21:46:50 goofy kernel: usb-uhci.c: interrupt, status 2, frame# 1393
Jan 27 21:46:53 goofy kernel: usb_control/bulk_msg: timeout
Jan 27 21:46:53 goofy kernel: visor.c: visor_startup - error getting first
unknown palm command
Jan 27 21:46:56 goofy kernel: usb_control/bulk_msg: timeout
Jan 27 21:46:56 goofy kernel: visor.c: visor_startup - error getting second
unknown palm command
Jan 27 21:46:56 goofy kernel: usbserial.c: Handspring Visor / Palm 4.0 / Clié
4.x converter now attached to ttyUSB0 (or usb/tts/0 for devfs)
Jan 27 21:46:56 goofy kernel: usbserial.c: Handspring Visor / Palm 4.0 / Clié
4.x converter now attached to ttyUSB1 (or usb/tts/1 for devfs)
Jan 27 21:46:56 goofy kernel: usbserial.c: USB Serial support registered for
Sony Clié 3.5
Jan 27 21:46:56 goofy kernel: visor.c: USB HandSpring Visor, Palm m50x, Sony
Clié driver v1.6
Jan 27 21:46:56 goofy kernel: ide: no cache flush required.
Jan 27 21:46:56 goofy devlabel: devlabel service started/restarted
Jan 27 21:47:39 goofy kernel: usb.c: USB disconnect on device 00:1d.0-1 address 3
Jan 27 21:47:39 goofy kernel: usbserial.c: Handspring Visor / Palm 4.0 / Clié
4.x converter now disconnected from ttyUSB0
Jan 27 21:47:39 goofy kernel: usbserial.c: Handspring Visor / Palm 4.0 / Clié
4.x converter now disconnected from ttyUSB1

The disconnected message are from me cancelling the HotSync on the Clie itself.


Comment 4 Tammy Fox 2003-09-05 04:39:07 UTC
This somehow works now with RHL 9 + errata.