Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 821812

Summary: SELinux is preventing /usr/bin/ruby from 'getattr' accesses on the file /lib/systemd/fedora-configure.
Product: [Fedora] Fedora Reporter: al morris <allinux4>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: dominick.grift, dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:0eaa01e5146799a6675e926fccaee0e9708b2ffca1fd31f8dfe428448af05da4
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-15 19:53:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description al morris 2012-05-15 14:39:29 UTC
libreport version: 2.0.8
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.5-2.fc16.x86_64
reason:         SELinux is preventing /usr/bin/ruby from 'getattr' accesses on the file /lib/systemd/fedora-configure.
time:           Tue 15 May 2012 09:39:17 AM CDT

description:
:SELinux is preventing /usr/bin/ruby from 'getattr' accesses on the file /lib/systemd/fedora-configure.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that ruby should be allowed getattr access on the fedora-configure file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep deltacloudd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:deltacloudd_t:s0
:Target Context                system_u:object_r:initrc_exec_t:s0
:Target Objects                /lib/systemd/fedora-configure [ file ]
:Source                        deltacloudd
:Source Path                   /usr/bin/ruby
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           ruby-1.8.7.358-1.fc16.x86_64
:Target RPM Packages           initscripts-9.34.2-1.fc16.x86_64
:Policy RPM                    selinux-policy-3.10.0-84.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.5-2.fc16.x86_64 #1 SMP Tue May 8
:                              11:24:50 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Tue 15 May 2012 04:33:25 PM CDT
:Last Seen                     Tue 15 May 2012 04:33:26 PM CDT
:Local ID                      7a2a4933-3880-48bd-921e-5e55a49c2214
:
:Raw Audit Messages
:type=AVC msg=audit(1337117606.156:84): avc:  denied  { getattr } for  pid=1159 comm="deltacloudd" path="/lib/systemd/fedora-configure" dev="sda3" ino=393977 scontext=system_u:system_r:deltacloudd_t:s0 tcontext=system_u:object_r:initrc_exec_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1337117606.156:84): arch=x86_64 syscall=lstat success=yes exit=0 a0=1d80de0 a1=7fff77f4e520 a2=7fff77f4e520 a3=1 items=0 ppid=1108 pid=1159 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=deltacloudd exe=/usr/bin/ruby subj=system_u:system_r:deltacloudd_t:s0 key=(null)
:
:Hash: deltacloudd,deltacloudd_t,initrc_exec_t,file,getattr
:
:audit2allow
:
:#============= deltacloudd_t ==============
:allow deltacloudd_t initrc_exec_t:file getattr;
:
:audit2allow -R
:
:#============= deltacloudd_t ==============
:allow deltacloudd_t initrc_exec_t:file getattr;
:

Comment 1 Miroslav Grepl 2012-05-15 19:53:55 UTC

*** This bug has been marked as a duplicate of bug 821810 ***