Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 82019

Summary: Different locales in gdm dialogs
Product: [Retired] Red Hat Linux Beta Reporter: Thomas Woerner <twoerner>
Component: gdmAssignee: Owen Taylor <otaylor>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: RC3CC: laroche
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-03 20:24:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79578    

Description Thomas Woerner 2003-01-16 13:57:07 UTC
Description of problem:

gdm has different locales for the dialog buttons:
  Language: Rinonci, I Va
  Session: Cancel, Ok
  Reboot: Neni, Oyi

The system locale is en_US.UTF-8

Version-Release number of selected component (if applicable):

gdm-2.4.1.0-1

How reproducible:

always

Steps to Reproduce:
1. Install with locate en_US
2. Set init to 5
3. Click on Language, Session and Reboot
    
Actual results:

Different Languages

Expected results:

English Text

Comment 1 Owen Taylor 2003-01-16 21:14:47 UTC
Taking GDM target/blockers.

Comment 2 Owen Taylor 2003-01-17 00:03:34 UTC
I've never seen this on 4-5 installs in the last week or so, and nobody
else has reported it either. Do you have any idea about what is _different_
about your install? Are you still seeing it?


Comment 3 Owen Taylor 2003-01-20 21:54:47 UTC
Need hints on reproduction.

Comment 4 Thomas Woerner 2003-01-21 09:54:32 UTC
I have installed the beta4 (en_US) with german keyboard layout and have upgraded
to the last packages from beehive.

$ cat /etc/sysconfig/i18n
LANG="en_US.UTF-8"
SUPPORTED="en_US.UTF-8:en_US:en"
SYSFONT="latarcyrheb-sun16"
LC_COLLATE=C


Comment 5 Florian La Roche 2003-02-02 11:09:05 UTC
I've also seen this on several installations now. The language selection
displays the yes/no in some unusual language and it happened with some
other dialogs, too.

greetings,

Florian La Roche


Comment 6 Owen Taylor 2003-02-03 17:32:19 UTC
OK, it turns out this is reproducible by putting LC_COLLATE=C in 
/etc/sysconfig/i18n. No idea yet _why_ that would be the case.


Comment 7 Owen Taylor 2003-02-03 19:24:24 UTC
Filed upstream with explanation and fix as:

 http://bugzilla.gnome.org/show_bug.cgi?id=105145

Will build a new GDM with a patch.


Comment 8 Owen Taylor 2003-02-03 20:24:37 UTC
2.4.1.1-4 fixes the problem for me.