Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 82018

Summary: /usr/bin/find very bad behaviour (KERNEL BUG???)
Product: [Retired] Red Hat Linux Reporter: Javier Ros <jros>
Component: findutilsAssignee: Tim Waugh <twaugh>
Status: CLOSED NOTABUG QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-16 12:56:25 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Javier Ros 2003-01-16 12:54:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Im using find to search some ser of files within my file system
using the instruction:

To reproduce the problem, you can untar:

[jros@s172m203 etc]$ find ./ -type f -name '[^A-Z]*.*' -name '*' -print

It offer bad results

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
To reproduce the problem, you can:

1.- untar

www.imem.unavarra.es/redhat8.0bug/caca.tgz

to a directory of your convenience

2.- cd to the etc directory

3.- type the previous instruction

You will obtain a erroneous behaviour. Compare it against the behaviou in other
redhat distribution.

I did it with redhat7.0
    

Actual Results:  Bad behaviour in redhat8.0 outputs

[jros@s172m203 etc]$ find ./ -type f -name '[^A-Z]*.*' -name '*' -print
./conf/3d_mec.conf
./xpm/3d_mec.png


Expected Results:  Diferences between 7.0, correct behaviour an 8.0 bad.

The output in 7.0 is significatively longer.

Additional info:

IMPORTANT: The problem is not in find executable, I've tested it using a working
redhat 7.0 /usr/bin/find executable.

The same problem arises.

If triyed to obtain a correct behaviour using diferent filesystems, and ald
redhat 8.0 kernels. The problem is the same.

The problem is not computer or installation related, thought I've user other
redhat 8.0 distributions and the problem reproduces.

I'm not an expert but it seems to be a KERNEL related problem.

Comment 1 Tim Waugh 2003-01-16 12:56:25 UTC
You forgot to set LC_CTYPE=C in your environment.