Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 819927

Summary: SELinux is preventing restorecond from 'getattr' accesses on the filesystem /run.
Product: [Fedora] Fedora Reporter: Frank Murphy <frankly3d>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: dominick.grift, dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Unspecified   
Whiteboard: abrt_hash:76fb23f834fda13b64b1402053ef845654a34bf48c82de67d6e413b406467e19
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-28 01:20:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Frank Murphy 2012-05-08 16:04:35 UTC
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.4-5.fc17.i686
time:           Tue 08 May 2012 17:04:06 IST

description:
:SELinux is preventing restorecond from 'getattr' accesses on the filesystem /run.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that restorecond should be allowed getattr access on the run filesystem by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep restorecond /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:restorecond_t:s0
:Target Context                system_u:object_r:tmpfs_t:s0
:Target Objects                /run [ filesystem ]
:Source                        restorecond
:Source Path                   restorecond
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           filesystem-3-2.fc17.i686
:Policy RPM                    selinux-policy-3.10.0-121.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.4-5.fc17.i686 #1
:                              SMP Mon May 7 17:45:26 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    Tue 08 May 2012 16:57:33 IST
:Last Seen                     Tue 08 May 2012 16:57:33 IST
:Local ID                      096960bc-25ca-4e9c-b71d-5de86b7f1cdd
:
:Raw Audit Messages
:type=AVC msg=audit(1336492653.514:84): avc:  denied  { getattr } for  pid=2227 comm="restorecond" name="/" dev="tmpfs" ino=6330 scontext=system_u:system_r:restorecond_t:s0 tcontext=system_u:object_r:tmpfs_t:s0 tclass=filesystem
:
:
:Hash: restorecond,restorecond_t,tmpfs_t,filesystem,getattr
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:

Comment 1 Daniel Walsh 2012-05-08 16:27:39 UTC
Fixed in selinux-policy-3.10.0-123.fc17

Comment 2 Daniel Walsh 2012-05-08 16:27:51 UTC
*** Bug 819923 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2012-05-09 15:17:36 UTC
selinux-policy-3.10.0-124.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-124.fc17

Comment 4 Fedora Update System 2012-05-17 22:57:37 UTC
Package selinux-policy-3.10.0-125.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-125.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7953/selinux-policy-3.10.0-125.fc17
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2012-05-28 01:20:04 UTC
selinux-policy-3.10.0-125.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.