Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 81958

Summary: changing $0 / $PROGRAM_NAME has no effect
Product: [Retired] Red Hat Linux Reporter: Jonathan Schatz <jon>
Component: perlAssignee: Chip Turner <cturner>
Status: CLOSED CURRENTRELEASE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-04-22 14:45:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
a small test case for this bug none

Description Jonathan Schatz 2003-01-15 19:36:28 UTC
Description of problem:
assigning a value to $0 or $PROGRAM_NAME has no effect

Version-Release number of selected component (if applicable):

[jon@jonschatz-lx jon]$ rpm -q perl
perl-5.8.0-55


How reproducible:
every time.

Steps to Reproduce:

run the test case i'll attach after i submit this.

Actual results:
the test case fails.

Expected results:
the test case should pass.

Additional info:

Comment 1 Jonathan Schatz 2003-01-15 19:37:53 UTC
Created attachment 89385 [details]
a small test case for this bug

this fails with assigning to $0 and with $PROGRAM_NAME. comment out one or the
other to see it fail with either.

Comment 2 Jonathan Schatz 2003-08-28 00:08:44 UTC
this seems to be fixed in rh9.0 with:

[jon@jonschatz-lx jon]$ rpm -q perl
perl-5.8.0-88