Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 81941

Summary: metacity moves the window that is being raised to the current workspace
Product: [Retired] Red Hat Raw Hide Reporter: Sam Steingold <sds>
Component: metacityAssignee: Christopher Blizzard <blizzard>
Status: CLOSED RAWHIDE QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: hp
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: athlon   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-10-24 14:32:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79579, 100644    

Description Sam Steingold 2003-01-15 16:00:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
I have several workspaces and the only mozilla window is open (not iconified!)
in workspace 2, and an xterm in workspace 1.
I type in the xterm:
$ mozilla -remote 'openUrl(http://www.gnu.org,new-tab)'
I expect the GNU page to be opened in the (only) mozilla window which should
stay in workspace 2 (this is what happened in mozilla 1 and in mozilla 1.2.1 as
distributed by mozilla.org).
Instead, in mozilla 1.2.1 as distributed with phoebe, the mozilla window appears
in the workspace 1, obscuring my xterm.

Version-Release number of selected component (if applicable):  1.2.1


How reproducible:
Always

Steps to Reproduce:
1. mozilla in workspace 2
2. xterm in workspace 1
3. in xterm: 
   $ mozilla -remote 'openUrl(http://www.gnu.org,new-tab)'


Actual Results:  mozilla window appears in the workspace 1 (one - where the
xterm is)

Expected Results:  mozilla window stays in the workspace 2 (two - where it
always was)

Additional info:

this worked as espected with moz 1 (rh8) and moz 1.2.1 as distributed by
mozilla.org, but breaks with moz 1.2.1 as distributed with phoebe.

Comment 1 Christopher Blizzard 2003-01-15 17:47:31 UTC
This is using gtk 1.2 so I don't know why it would be switching desktops.  It
does try to raise itself (as it should) but it certainly shouldn't be switching
desktops.

Comment 2 Havoc Pennington 2003-01-15 17:54:16 UTC
Can you confirm that you're using or not using metacity window manager?

Comment 3 Sam Steingold 2003-01-15 18:05:05 UTC
I am using whatever came with phoebe by default - yes, it is metacity.

Comment 4 Sam Steingold 2003-01-21 23:36:45 UTC
this is __NOT__ mozilla-specific!
I just got the same symptom with emacs, so I changed the summary.

Comment 5 Havoc Pennington 2003-01-21 23:48:35 UTC
I fixed this in metacity CVS, we'll get the fix next time we upgrade version.

Comment 6 Christopher Blizzard 2003-10-24 14:32:43 UTC
I'm going to assume that this was picked up, since this was fixed in cvs a long
time ago.