Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 81928

Summary: modprobe fails to load serial_cs.o
Product: [Retired] Red Hat Public Beta Reporter: David Woodhouse <dwmw2>
Component: modutilsAssignee: Bill Nottingham <notting>
Status: CLOSED NOTABUG QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: phoebeCC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-15 18:58:07 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 79578    

Description David Woodhouse 2003-01-15 10:30:50 UTC
Loading PCMCIA serial module seems to fail for unknown reason. Other modules
load OK, serial_cs.o.gz is correctly listed in modules.dep. 

[root@host223 linux-2.4.20-2.2]# modprobe serial_cs
modprobe: Can't locate module serial_cs
[root@host223 linux-2.4.20-2.2]# insmod serial_cs
Using /lib/modules/2.4.20-2.2/kernel/drivers/char/pcmcia/serial_cs.o.gz

Even loading synclink_cs.o from the same directory works OK, albeit with a
whinge about tainting the kernel.

Comment 1 Bill Nottingham 2003-01-15 17:04:05 UTC
Works for me with modutils-2.4.22-3; kernel-2.4.20-2.15.

Comment 2 David Woodhouse 2003-01-15 18:58:07 UTC
Removing 'alias serial_cs 8250_cs' from modules.conf seems to help :)