Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 819177

Summary: [atl1c] NETDEV WATCHDOG transmit queue 0 timed out
Product: [Fedora] Fedora Reporter: James Ettle <james>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-05 15:31:07 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
full dmesg with the problem none

Description James Ettle 2012-05-05 11:23:36 UTC
Created attachment 582281 [details]
full dmesg with the problem

Description of problem:
Atheros Communications AR8151 v2.0 Gigabit Ethernet (rev c0) chip, with atl1c driver. Unplugged ethernet cable, then reinserted. Shortly afterwards, the following showed up:


[  862.723052] atl1c 0000:04:00.0: atl1c: p5p1 NIC Link is Down
[  876.040759] atl1c 0000:04:00.0: atl1c: p5p1 NIC Link is Up<1000 Mbps Full Duplex>
[  881.798022] ------------[ cut here ]------------
[  881.798041] WARNING: at net/sched/sch_generic.c:256 dev_watchdog+0x240/0x250()
[  881.798046] Hardware name: A15A/HE/HC
[  881.798051] NETDEV WATCHDOG: p5p1 (atl1c): transmit queue 0 timed out
[  881.798055] Modules linked in: coretemp ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast bnep ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables iptable_nat nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack snd_hda_codec_hdmi arc4 uvcvideo ath9k snd_hda_codec_conexant videobuf2_vmalloc videobuf2_memops videobuf2_core ath9k_common videodev media iTCO_wdt ath9k_hw snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_page_alloc ath3k btusb ath bluetooth mac80211 cfg80211 iTCO_vendor_support microcode snd_timer snd atl1c i2c_i801 serio_raw rfkill soundcore uinput binfmt_misc wmi i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: scsi_wait_scan]
[  881.798160] Pid: 0, comm: swapper/0 Not tainted 3.3.4-3.fc17.x86_64 #1
[  881.798165] Call Trace:
[  881.798168]  <IRQ>  [<ffffffff810568af>] warn_slowpath_common+0x7f/0xc0
[  881.798190]  [<ffffffff810569a6>] warn_slowpath_fmt+0x46/0x50
[  881.798200]  [<ffffffff814fcdd0>] dev_watchdog+0x240/0x250
[  881.798208]  [<ffffffff814fcb90>] ? dev_deactivate_queue.constprop.30+0x80/0x80
[  881.798221]  [<ffffffff81066011>] run_timer_softirq+0x141/0x340
[  881.798229]  [<ffffffff8105dc90>] __do_softirq+0xc0/0x1e0
[  881.798237]  [<ffffffff8101aba3>] ? native_sched_clock+0x13/0x80
[  881.798247]  [<ffffffff815f4ddc>] call_softirq+0x1c/0x30
[  881.798257]  [<ffffffff81015465>] do_softirq+0x75/0xb0
[  881.798263]  [<ffffffff8105e055>] irq_exit+0xb5/0xc0
[  881.798272]  [<ffffffff815f572e>] smp_apic_timer_interrupt+0x6e/0x99
[  881.798280]  [<ffffffff815f43de>] apic_timer_interrupt+0x6e/0x80
[  881.798284]  <EOI>  [<ffffffff81318246>] ? intel_idle+0xe6/0x150
[  881.798298]  [<ffffffff81318227>] ? intel_idle+0xc7/0x150
[  881.798310]  [<ffffffff8149ddf7>] cpuidle_idle_call+0xb7/0x230
[  881.798319]  [<ffffffff8101220f>] cpu_idle+0xaf/0x120
[  881.798327]  [<ffffffff815c9ede>] rest_init+0x72/0x74
[  881.798339]  [<ffffffff81aedc00>] start_kernel+0x3ba/0x3c5
[  881.798348]  [<ffffffff81aed346>] x86_64_start_reservations+0x131/0x135
[  881.798356]  [<ffffffff81aed44a>] x86_64_start_kernel+0x100/0x10f
[  881.798362] ---[ end trace 44ae51280819d503 ]---


Network connection seemed to continue to work properly. Full dmesg attached.

Version-Release number of selected component (if applicable):
kernel-3.3.4-4.fc17.x86_64
linux-firmware-20120206-0.3.git06c8f81.fc17.noarch

Comment 1 Josh Boyer 2012-05-05 15:31:07 UTC

*** This bug has been marked as a duplicate of bug 717211 ***