Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 81850

Summary: gnome-sound-recorder crashes on exit while playing
Product: [Retired] Red Hat Linux Reporter: David Balažic <david.balazic>
Component: gnome-mediaAssignee: John (J5) Palmieri <johnp>
Status: CLOSED CANTFIX QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: jkeck, srevivo, tomg
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-10-18 18:22:11 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79579, 100644    
Attachments:
Description Flags
backtrace for crash in #81850 none

Description David Balažic 2003-01-14 18:09:01 UTC
Description of problem:

gnome-sound-recorder crashes if exited during playback of a file

start it, load a wav ( /usr/games/chromium/data/wav/music_game.wav ), press 
play, press [X] ( close window button ). I get the above messages ( the ones 
starting with "(gnome-sound-recorder:2745):..." ) and a gnome error dialog ( 
segmentation fault ).


Version-Release number of selected component (if applicable):

gnome-media-2.1.3-2

How reproducible:


Steps to Reproduce:
1. start gnome-sound-recorder
2. load a wave file ( I used /usr/games/chromium/data/wav/music_game.wav )
3. press play
4. press [X] ( window close button , on the top right corner )
    
Actual results:

GNOME error dialog appears , complaining about a "segmentation fault".

Expected results:

program exits normally

Additional info:

If I run it from a terminal, I get the following output :

[stein@localhost stein]$ gnome-sound-recorder
INFO ( 2745: 0) Initializing GStreamer Core Library version 0.5.0
INFO ( 2745: 0) CPU features: (c1c7fbff) MMX 3DNOW MMXEXT
registry: loaded global_registry in 0,258758 seconds
          (/var/cache/gstreamer-0.5/registry.xml)
DEBUG: bytes per sample: 1
DEBUG: pad_query done, value 14636009070
 
(gnome-sound-recorder:2745): Bonobo-CRITICAL **: file bonobo-ui-component.c: 
line 1206 (impl_set_prop): assertion `container != CORBA_OBJECT_NIL' failed
 
(gnome-sound-recorder:2745): Bonobo-CRITICAL **: file bonobo-ui-component.c: 
line 1206 (impl_set_prop): assertion `container != CORBA_OBJECT_NIL' failed
 
(gnome-sound-recorder:2745): Bonobo-CRITICAL **: file bonobo-ui-component.c: 
line 1206 (impl_set_prop): assertion `container != CORBA_OBJECT_NIL' failed
 
(gnome-sound-recorder:2745): Bonobo-CRITICAL **: file bonobo-ui-component.c: 
line 1206 (impl_set_prop): assertion `container != CORBA_OBJECT_NIL' failed
 
(gnome-sound-recorder:2745): Bonobo-CRITICAL **: file bonobo-ui-component.c: 
line 1206 (impl_set_prop): assertion `container != CORBA_OBJECT_NIL' failed
 
(gnome-sound-recorder:2745): Bonobo-CRITICAL **: file bonobo-ui-component.c: 
line 635 (impl_xml_set): assertion `container != CORBA_OBJECT_NIL' failed
 
(gnome-sound-recorder:2745): GLib-GObject-WARNING **: invalid uninstantiatable 
type `<invalid>' in cast to `GtkRange'
[stein@localhost stein]$

Comment 1 Havoc Pennington 2003-01-14 21:17:27 UTC
Do you get a backtrace? Can you paste that here and reopen?

Comment 2 David Balažic 2003-01-17 14:20:42 UTC
How do I know if I get a backtrace ?
I already posted everything that is printed in the shell window.


Comment 3 Havoc Pennington 2003-02-03 21:08:40 UTC
The gnome error dialog has "submit a bug report," the simplest way to get a
backtrace is to submit the bug report, then add a link here to the bug report
that gets created on gnome.org. 

Or "show debug details" on the first page of the bug report wizard, and
cut-and-paste the trace. 

ideally, install gnome-media-debuginfo first

Comment 4 tom georgoulias 2003-03-19 04:08:03 UTC
Created attachment 90656 [details]
backtrace for crash in #81850

I've seen the same bug and here's the report bug buddy helped me generate.

Comment 5 Colin Walters 2004-07-26 17:37:53 UTC
Hi, I can't reproduce this with the FC2 gnome-sound-recorder.  Can you?

Comment 6 Bill Nottingham 2006-10-18 18:22:11 UTC
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.