Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 81718

Summary: Japanese text installer fails to show the string tails
Product: [Retired] Red Hat Public Beta Reporter: Nakai <ynakai>
Component: anacondaAssignee: Matt Wilson <msw>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: high Docs Contact:
Priority: high    
Version: phoebeCC: eng-i18n-bugs, mitr, msw, wtogami, yshao
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-06 16:55:06 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79578    

Description Nakai 2003-01-13 10:13:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.0.1) Gecko/20020830

Description of problem:
Japanese text installer sometimes don't show the full
text and string tail is cut.

So users cannot get full information within the
installation process and it might cause serious install
mistake.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run text installer in Japanese mode.
2. Oops.
3.
    

Additional info:

Comment 1 Eido Inoue 2003-01-13 17:53:49 UTC
Which screen? Which line?

Comment 2 Eido Inoue 2003-01-13 19:26:56 UTC
never mind... I see it in re0113.0... Matt, Mike: something has regressed since
the first builds. You can see how the "Welcome to Red Hat Linux" in Japanese is
broken into two lines.

Looks like the reflow in newt isn't working. Also, the number of scan lines
isn't being detected properly anymore; lots of black at the bottom of the screen.

Comment 3 Eido Inoue 2003-01-13 19:39:09 UTC
FWIW, I can't reproduce the problem by firing up any of the config tools from
launching the command line (within diet/wlite linked bterm). Can reproduce only
from the built images.

Comment 4 Eido Inoue 2003-01-14 05:37:48 UTC
last build where it works is the 11th. it breaks from the 12th onwards. neither
newt, bogl, ncurses changed.

looking into it...


Comment 5 Matt Wilson 2003-01-14 06:39:14 UTC
I was wrong, it was between re0109 and re0110


Comment 6 David Joo 2003-01-29 07:02:33 UTC
*** Bug 82983 has been marked as a duplicate of this bug. ***

Comment 7 David Joo 2003-01-29 07:03:28 UTC
It is happening across all CJKs.

Comment 8 Jeremy Katz 2003-01-29 14:04:06 UTC
*** Bug 82983 has been marked as a duplicate of this bug. ***

Comment 9 Jeremy Katz 2003-01-31 22:42:00 UTC
I think I have this fixed in CVS -- should be fixed in nightly trees for
tomorrow/beginning of next week.

Comment 10 Leon Ho 2003-02-04 04:42:28 UTC
It is still showing in latest tree. ie.: 
 
- The footer only shows until 3/4 of the line for CJK. Afterward it is "English" - 
look like it has not redraw probably? 
 
- in Disk Druid 
	- it only shows until "Start" word in the header of disk table, the rest are 
missing. 
	- it cannot shows last character for "free space" in JP 
 

Comment 11 Matt Wilson 2003-02-04 06:43:29 UTC
the help lines can be fixed with a patch I made.  The disk druid column headers
is a snack.py bug that will take longer.
-

Comment 12 Matt Wilson 2003-02-04 16:53:59 UTC
found disk druid bug.  should be fixed soon.  these were newt bugs.


Comment 13 Jeremy Katz 2003-02-06 02:16:22 UTC
Fixed in newer newt

Comment 14 Jay Turner 2003-02-06 13:32:57 UTC
Adrian, can you poke through the latest installer trees and make sure that
everything looks good?  Thanks.

Comment 15 Eido Inoue 2003-02-06 16:55:06 UTC
they look good as of yesterday. closing.