Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 81658

Summary: Mozilla mail does not display folders when run from KDE
Product: [Retired] Red Hat Public Beta Reporter: Elton Woo <elwoo>
Component: mozillaAssignee: Christopher Blizzard <blizzard>
Status: CLOSED NOTABUG QA Contact: Ben Levenson <benl>
Severity: high Docs Contact:
Priority: medium    
Version: phoebe   
Target Milestone: ---   
Target Release: ---   
Hardware: athlon   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-13 06:04:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Elton Woo 2003-01-12 07:57:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
When mozilla mail is opened on the KDE desktop, it shows only its window frames,
but nothing shows where the normal folders (sent, inbox, trash, local folders, etc)
should be.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.login into KDE desktop
2.start mozilla then mozilla mail from the browser frame OR
3.launch mozilla-mail by itself from the KDE menu.
    

Actual Results:  Main mozilla-mail window opens, but does not display any mail,
local folders, or news group folders. If, at this point, one attempts to run the
Account Wizard, the New Account Settings dialog will hang, as will mozilla mail.

NOTE: the browser displays its side-pane contents as it normally would in Gnome.

Expected Results:  Mailer should display folders and contents so that mail may
be read, or otherwise managed, including composition of new messages.

Additional info:

could this be related to a memory leak?

Comment 1 Elton Woo 2003-01-13 06:04:33 UTC
since upgrading system packages from rawhide (up to Jan. 10), this problem
has disappered. I am now able to use the Mozilla mailer in KDE as I can in
Gnome.

Comment 2 Christopher Blizzard 2003-01-15 17:42:49 UTC
I think this is KDE's bogo-session management.  It restarts mozilla-bin instead
of the mozilla wrapped script which means that some of the library paths aren't
set properly.