Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 81617

Summary: cvs-1.11.2-5.i386 hangs with cvs-1.11.1p1-3 clients
Product: [Retired] Red Hat Linux Reporter: Andrew Morton <akpm>
Component: cvsAssignee: Eido Inoue <havill>
Status: CLOSED CURRENTRELEASE QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: mitr, tibbs
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-10-29 18:15:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Andrew Morton 2003-01-11 07:06:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

Description of problem:
I just installed rh8.0.  A standard CVS setup works OK
to localhost but when I try to check something out over 
ethernet, both client and server hang.

The client is cvs-1.11.1p1-3.

A command like cvs co dbench get stuck, client is waiting
or TCP data (stuck in tcp_data_wait) and the server is also
in interruptible sleep.  Looks like  protocol failure and each
end is waiting for the other.

downgrading the cvs on the server (rh8.0) to cvs-1.11.1p1-7
fixed it up.

And upgrading the client from  cvs-1.11.1p1-3 to cvs-1.11.2-5.i386
fixed it up too.

So it appears that cvs-1.11.1p1-3 and cvs-1.11.2-5.i386 will
not talk to each other.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. See above
2.
3.
    

Additional info:

See above

Comment 1 Jason Tibbitts 2003-01-14 15:51:20 UTC
I believe I'm having the same issue; I can't get the user to tell me the client
info at the moment, but the symptoms are the same: the client just stops in the
middle of a checkout; both sides will wait indefinitely for in a read. 
Unfortunately I can't duplicate it on any of the machines I have access to.

To be fair, I am running the cvs-1.11.2-5 RPM with one extra patch (to export
CVS_Username to an environment variable) rebuilt on a 7.2 machine.  None of this
should make any difference to the networking, however.

Comment 2 Henrik Nordstrom 2003-06-10 15:40:22 UTC
I probably experience the same problem seen on RedHat 9 
cvs-1.11.2-10.i386.rpm. 
 
Upgrade to rawhide cvs-1.11.5-2 resolved the problem for me, rebuilt from 
source as no binary was available in the rawhide mirror I use... 
 
In my case the problem is compression (-z) which is broken for older CVS 
clients in 1.11.2 (see cvs 1.11.3 release notes), but have also seen much 
worse effects (100% CPU usage until manually killed cvs server processes) in 
another installation of 1.11.2.