Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 81534

Summary: FR install's password doesn't work with GDM
Product: [Retired] Red Hat Public Beta Reporter: David Joo <djoo>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: phoebeCC: eng-i18n-bugs, mitr
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: qa-i18n
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-31 18:53:06 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 79579    

Description David Joo 2003-01-10 04:12:54 UTC
Description of problem:
When you install choose password as "123123" then after installation try to
login as root it will say authentication failed.

Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1. install Pheobe
2. choose normal French as only lang
3. Choose normal French as keyboard (since it has (accented 'e' maped to 2 in
keyboard)
4. Set root password to "123123"
5. Finish installation
6. Try to login from GDM using root account
7. Try to login from VC using root account
    
Actual results:
from GDM, you won't be able to login but from VC you can log in.


Expected results:
Where ever, you should be able to log in.

Additional info:
French Keyboard mapping is different from VC and X.
for example after you log into console and type 123 then it would look like &{"
but after you log
into X then type 123 it will look like &e(with accent)"

Comment 1 Miloslav Trmac 2003-01-10 13:33:56 UTC
Duplicate of bug 74264.
The original analysis there is probably wrong (and nobody seems to care ;-),
but the point is that keymaps must be loaded with
loadkeys -u
^^^^^^^^^^^
when UTF-* is used

Comment 2 Jeremy Katz 2003-01-15 02:21:03 UTC
Did you do 123123 on the keyboard or shifted of each number key (shift-1 -> 1 on
a french keyboard layout)?

Comment 3 David Joo 2003-01-15 02:33:49 UTC
I was trying to get '&e(accented)"' which is 123 in keyboard... so no shift

Comment 4 Jeremy Katz 2003-01-23 22:59:46 UTC
The only sensible thing to do with passwords is enforce them as ascii.  The
passwd file has no defined encoding so there's no way to keep consistency
otherwise.  Enforced in CVS

Comment 5 Jay Turner 2003-01-31 18:53:06 UTC
anaconda-8.0.94-0.20030130230242 no longer allows the input of non-ASCII
characters in passwords.  Will check user creation in firstboot as well, as that
would be affected by the same issue.