Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 81488

Summary: Use the same default background color as bluecurve
Product: [Retired] Red Hat Linux Reporter: louisgtwo
Component: libgnomeAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED WONTFIX QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 9CC: alexl, mitr, otaylor, pbrown, wtogami
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-05-31 19:37:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79579, 100644    
Attachments:
Description Flags
modifies background color for bluecurve none

Description louisgtwo 2003-01-09 21:42:03 UTC
if RH8.1 is going to use the same default desktop background as 8.0 this patch
make the default background color be the same as bluecurve. This patch minimizes
the flash effect when you login before nautilus draws the background. This patch
is alreadey included in libgnome but I have modified it for bluecurve.

Comment 1 louisgtwo 2003-01-09 21:43:05 UTC
Created attachment 89257 [details]
modifies background color for bluecurve

Comment 2 Havoc Pennington 2003-01-09 22:11:43 UTC
Good idea.

Comment 3 louisgtwo 2003-01-09 22:28:30 UTC
If you can change XFree86 root window's color to be the same I believe this
would be completely unnoticeable.

Comment 4 Havoc Pennington 2003-01-09 22:53:19 UTC
Indeed, why don't we make the default xfree root window color match 
the bluecurve color, instead of black?

Comment 5 louisgtwo 2003-01-10 00:35:27 UTC
Actually, I was talking about that lighter shade of blue (aqua?), before the
splash screen come on. This is in init 5 login in from gdm, not starting X from
the console.


Comment 6 Mike A. Harris 2003-01-11 07:16:07 UTC
One of the X11 specifications, specifies that the root window must be
comprised of blackpixel and whitepixel.  I don't have the precice
citation handy however, but I could look it up if need be, although
it would waste some time to do so.

Comment 7 Havoc Pennington 2003-01-11 07:34:11 UTC
As Keith points out, you can just as well ignore that spec, since an app 
can't rely on the root window being whitepixel/blackpixel anyway - another 
app may have changed the root window color at any time, such as xsetroot.

But he also says that video hardware is going to require clearing to black to 
reset the video card anyway, so there's not much to gain.

Comment 8 Ray Strode [halfline] 2005-05-12 15:52:04 UTC
Hi,
I'm going through bugs assigned to me and attempting to clean some of the older,
fixed ones up.

This bug hasn't changed in over a year old now.  Are you still seeing the problem? 

(This a batch message is being sent to all my bugs that haven't changed in a year)

Comment 9 Ray Strode [halfline] 2005-05-31 19:37:31 UTC
Hi,

This bug has been in the NEEDINFO state for at least a couple of weeks now.  I'm
going to close the bug, but if you can provide the required information feel
free to open a new report.

Thanks.

(This is a mass message being sent to a bunch of bug reports)