Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 81477

Summary: The ability to override hostname from reverese-lookup
Product: [Retired] Red Hat Linux Reporter: Daniel Resare <noa-bugzilla-redhat>
Component: initscriptsAssignee: Bill Nottingham <notting>
Status: CLOSED WONTFIX QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: mitr, rvokal, wtogami
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-09-30 18:25:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Daniel Resare 2003-01-09 20:08:42 UTC
Description of problem:

I get an ugly unreadable hostname from my isp's dhcp-server when i get my
ip-address. Therefore I was happy to see that there is an option to add an
optional hostname to use when dhcp is in use. However, that feature seems broken
or at least working in a non-intuitive way on my machine

Version-Release number of selected component (if applicable):
redhat-config-network-1.1.86-1

How reproducible:
always I suppose, haven't tried around much

Steps to Reproduce:
1. install the system, http install, selecting dhcp in installation
2. open redhat-config-network, create a new dhcp connection (due to #81071)
3. enter a nice hostname (in my case ulysses.resare.com) in the Hostname field
of the DHCP Settings box
4. Restart the network, or restart the computer
    
Actual results:
Hostname is still the ugly one provided by the isp

Expected results:
The nice hostname i entered in the box

Additional info:
ulysses.resare.com resolves to the ip that the machine recieves from the isp

the old hostname is still filled in in the Hostname field in the DNS tab

Comment 1 Harald Hoyer 2003-01-13 10:40:02 UTC
the hostname is a hint for dhcp, which hostname your machine would like to have.
I should change the field description or provide a tooltip for this.
For your nice hostname, please talk to your local network administrator, to
change the reverse ip resolution on your local DNS server.

Comment 2 Daniel Resare 2003-01-15 22:36:54 UTC
Heh, for many (most?) of us talking to the reverse dns operator is not an
option. A way to override what the reverse lookup gives us would be really nice.

Changing severity to "Enhancement".

ps. isnt c-541a72d5.01-60-6c6b701.cust.bredbandsbolaget.se a fabulous shorthand
for 213.114.26.84 :P

Comment 3 Harald Hoyer 2003-02-05 12:08:32 UTC
could not be done within redhat-config-network alone. This is first initscripts
or dhcpdclients job

Comment 4 Bill Nottingham 2005-09-30 18:25:38 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

Changing the hostname to something else that may not necessarily resolve in DNS
isn't something we'd specifically support.