Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 81449

Summary: upgrade replaces deliberately removed files
Product: [Retired] Red Hat Linux Reporter: Neil Prockter <prockter>
Component: logrotateAssignee: Elliot Lee <sopwith>
Status: CLOSED NOTABUG QA Contact: Jay Turner <jturner>
Severity: high Docs Contact:
Priority: medium    
Version: 8.0CC: michael, srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-09 23:02:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Neil Prockter 2003-01-09 16:42:23 UTC
Description of problem: I don't want logrotate restarting apache EVER. I remove
/var/logrotate.d/apache but upgrading puts it back again. Can an upgrade be made
to not recreated files that have been removed? Alternatively can some sense be
added to logrotate? alternatively can we have a version of logrotate that never
restarts system daemons


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. remove /etc/logrotate.d/apache
2. upgrade
3.
    
Actual results:
apache gets restarted every day

Expected results:
leave apache alone

Additional info:
if I've changed my apache config logrotate applies it! very bad!

Comment 1 Michael Lee Yohe 2003-01-09 17:12:31 UTC
Resolution == NOTABUG

The way the packages are distributed by Red Hat, you will have the behavior you
don't like.  Therefore, if you upgrade a package, RPM will restore the
filesystem will the hierarchy that the packager (Red Hat) has determined.

For your other requests, you should simply open an RFE (request for enhancement)
bug to ask for logrotate to not restart daemons -- this is because your request
is a completely separate issue.

Comment 2 Neil Prockter 2003-01-09 23:02:24 UTC
fair enough I've submitted a few enhancement request

Many Thanks