Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 81439

Summary: X crashes after NVidia driver update
Product: [Retired] Red Hat Linux Reporter: Sal Cirabisi <cirabisi>
Component: XFree86Assignee: Mike A. Harris <mharris>
Status: CLOSED DUPLICATE QA Contact: David Lawrence <dkl>
Severity: high Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: athlon   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:51:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Sal Cirabisi 2003-01-09 15:21:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
My pertinent system info: AMD1400 t-bird; 512mb RAM; NVIDIA GeForce 2 MX 400 
video card; Gateway 1510 monitor



After initial install in which X works but needs a driver update for video to 
work properly. I tried to intall both NVIDIA_kernel and NVIDIA_GLX, versions 
4190 and 3123, to no avail. X crashes and will try to reconfigure itself to no 
avail also. Not sure if this is an XFree issue or a kernel issue???

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Logout of X and run Command "init 3" to shutdown X.  
2. "Tar" NVIDIA drivers. Got to tar'd directories and run "make" and "make 
install":works fine. Drivers install okay. 
3. Run "lsmod" to ensure new "nvidia" driver loaded: it did every time.
4. Change driver data from "nv" to "nvidia" in /etc/X11/XF86Config-4
5. Run "init 5" and X tries to load but fails.
6. Review /var/log/XF86Free0.log and there is NO error/warning to indicate why 
driver will not install.
    

Actual Results:  Crash

Expected Results:  Crash

Additional info:

Comment 1 Sal Cirabisi 2003-01-09 18:32:01 UTC
Followup: I tried one more time to load the drivers. I did two things 
differnetly though. 1. I changed the /etc/X11/XF86Config (not the -4 file) and 
2. ran "depmod -a". Rebooted and guess what? Version 4191 loaded!

I will rename XF86Config-4 to see if it was the depmod that did it or not.

 

Comment 2 Mike A. Harris 2003-01-09 23:19:55 UTC

*** This bug has been marked as a duplicate of 73733 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:51:02 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.