Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 81364

Summary: rpmbuild can't see LDAP user
Product: [Retired] Red Hat Raw Hide Reporter: Jonathan Kamens <jik>
Component: openldapAssignee: Jay Fenlason <fenlason>
Status: CLOSED CANTFIX QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: jfeeney, notting, srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-09-03 07:37:06 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 79579, 100644    

Description Jonathan Kamens 2003-01-08 15:43:43 UTC
After upgrading to the current Raw Hide (as of yesterday) and attempting to
build from a spec file using rpmbuild, it complained "bad user/group" on one of
the source files listed in the spec file.  The user in question is listed in
LDAP but not in the local passwd file.  After adding the user to the local
passwd file, the problem went away.  jbj said I should report this under the
openldap component rather than under rpm because "rpm doesn't know anything
about LDAP" or some such thing.  I suppose it could also be a glibc bug.

Comment 1 Bill Nottingham 2006-08-08 02:03:53 UTC
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux.
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues were not resolved in a more
timely manner. However, we do want to make sure that important 
don't slip through the cracks. If these issues are still present
in a current release, such as Fedora Core 5, please move these
bugs to that product and version. Note that any remaining Red Hat
Raw Hide bugs will be closed as 'CANTFIX' on September 30, 2006.
Thanks again for your help.


Comment 2 Jonathan Kamens 2006-09-03 07:37:06 UTC
I no longer have any way of testing for this bug, and I suspect that nobody else
cares about it, so closing it.