Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 8134

Summary: setclock: mktime() failed unexpectedly (rc -1)
Product: [Retired] Red Hat Linux Reporter: Le Tanou Jerome <jerome.le-tanou>
Component: timeconfigAssignee: Trond Eivind Glomsrxd <teg>
Status: CLOSED DUPLICATE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-01-03 16:06:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Le Tanou Jerome 2000-01-03 09:32:00 UTC
Since 01/01/2000 :

[root@angelus /root]# cat /etc/sysconfig/clock
UTC=false
ARC=false
[root@angelus /root]# setclock
mktime() failed unexpectedly (rc -1).  Aborting.
[root@angelus /root]# date
Mon Jan  3 09:31:38 CET 2000
[root@angelus /root]# rpm -qf /usr/sbin/setclock
timeconfig-2.5-1

After a reboot, the problem disappears :

[root@angelus /root]# date
Mon Jan  3 10:40:57 CET 2000
[root@angelus /root]# setclock
[root@angelus /root]#

Comment 1 Bill Nottingham 2000-01-03 16:06:59 UTC
*** This bug has been marked as a duplicate of 8123 ***