Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 81279

Summary: "Update" and "Apply Errata" buttons easily confused
Product: Red Hat Network Reporter: Fred Bacon <bacon>
Component: RHN/Web SiteAssignee: Mike Orazi <morazi>
Status: CLOSED WONTFIX QA Contact: Red Hat Satellite QA List <satellite-qa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: RHN StableCC: alikins, bfaustyn, bretm, cturner, gdk, robin.norwood, taw
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
URL: https://rhn.redhat.com/network/systems/details/errata_list.pxt?sid=1001467227
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-02-12 17:45:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Fred Bacon 2003-01-07 15:13:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When checking the errata for a system, two buttons appear on the left hand side.
 One says "Update" the other says "Select All".  On the right hand side is a
button saying "Apply Errata".  Since a user is attempting
to update their system, the natural behavior would be for them to click on the
"Update" button to complete the action.  This is particularly true for cultures
where reading is from left to right.  You see the "Update" button long before
you see the "Apply Errata" button.  I believe that the button currently labeled
"Update" would be more appropriately labeled as "Refresh", since this is the
intended behavior.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Go to list of systems.
2.Select a system with errata available.
3.Click on the Errata tab.
    

Additional info:

Comment 1 Bill C. Riemers 2008-02-12 17:45:03 UTC
I see the button name has been changed to "Update List" instead of just
"Update".  I agree that "Refresh" would be more meaningful for this particular
page, but it would be confusing because all other RHN pages use "Update List" as
well.