Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 81225

Summary: Fails to install ATI FireGL 8800
Product: [Retired] Red Hat Linux Reporter: Erik Ringius <erik.ringius>
Component: XFree86Assignee: Mike A. Harris <mharris>
Status: CLOSED DUPLICATE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: msf
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:50:58 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 82776    

Description Erik Ringius 2003-01-06 21:51:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
The card is recognized as ATI FireGL 8800. 
An /etc/X11/XF86Config is made by pyxf86config with radeon as driver. 
#startx 
gives only a crash. 
Installing the ATI driver fglrx-glc22-4.2.0-2.5.1.i586.rpm does not help.
The ATI driver worked without problem with RH 8.0 and a suitable XF86Config
and with  
fglr200-glc22-4.2.0-1.4.3.i586.rpm I run RH 7.3 on same box.
fglr200-glc22-4.2.0-1.4.3.i586.rpm also works with mandrake 9.0 on same box
(I have several partitions with different distributions on the box)
SuSE 8.0 gets FireGL 8800 up in 2D in install.
SuSE 8.1 needs some manual editing of XF86Config.....

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run startx
2.
3.
    

Actual Results:  Xserver crashed, went back to console, and suggested a report
to xfree86 org

Expected Results:  x starts

Additional info:

2xP3@1000MHz GIGABYTE GA-6VXDC7 motherboard 1024MB RAM

Comment 1 Michael Fulbright 2003-01-08 20:15:02 UTC
Mike is there any known issues with this graphics card?

Comment 2 Mike A. Harris 2003-01-09 10:30:21 UTC
First the bad news, then the good news.

Bad news is, that proprietary 3rd party drivers are not supported by
Red Hat.  Just a helpful note however, that the driver you are attempting
to use, was designed for XFree86 4.2.0, and not for the version of XFree86
that is in phoebe.  You will not be able to use ATI's FireGL driver with
XFree86 4.2.99.x in phoebe/rawhide until XFree86 4.3.0 is officially
released, and ATI creates an updated version of their FireGL driver for
the new version of Red Hat Linux.  I don't know what ATI's release plans
are for the 4.3.0 release, but I suspect that they'll have an updated
driver for you to use not long after we make our official product release.

The good news is, that I have been implementing support for FireGL 8800/8700
for our upcoming release in the open source drivers we ship also.  Of course
the open source driver is not as full featured as the ATI FireGL drivers are,
however I hope to support both 2D, 3D, and Xv.  Once this is working properly,
you should be able to proceed through installation without problems, and
use X in a fresh Red Hat Linux install with 2D/3D/Xv with the Red Hat
supplied driver without needing the proprietary driver.

More good news:  I hope to have this working before the weekend.


Comment 3 Mike A. Harris 2003-01-17 08:45:37 UTC
Forgot to update report.

I've got this working now for quite a while.  I have not integrated it yet
though due to other pending changes in which multiple patches conflict
with each other.  Rest assured that this card will work in the final OS
release, and probably in a beta release as well.

I found an older bug that's a duplicate of this one that I couldn't
find before.  Closing as dupe.  Track the dupe to find out when I update
the package in rawhide.  Thanks.

Comment 4 Mike A. Harris 2003-01-17 08:50:22 UTC

*** This bug has been marked as a duplicate of 72790 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:50:58 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.