Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 81206

Summary: hidden parts of background image not cached?
Product: [Retired] Red Hat Linux Reporter: Daniel Resare <noa-bugzilla-redhat>
Component: nautilusAssignee: Alexander Larsson <alexl>
Status: CLOSED NEXTRELEASE QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: jroyse, srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-08-04 20:27:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Daniel Resare 2003-01-06 19:27:08 UTC
Description of problem:

When I select a background image in my Gnome environment, create a big window
and move it around, the background color is first visible until the background
image is redrawn when the clock cycles to do that are available

Version-Release number of selected component (if applicable):

XFree86-4.2.99.2-0.20021217.0
nautilus-2.1.5-2
control-center-2.1.3-1

How reproducible:
always

Steps to Reproduce:
1. select a large screen resolution on a fairly slow computer
2. switch desktop background to an image
3. start a program that creates a window and move it around
    
Actual results:

the parts of the background that becomes visible when the image is moved is
first filled with the background color that was before the background image was
selected, then a moment later the background image is "painted" in the area

Expected results:

as in redhat-8, the background image is displayed directly and not "painted"
in later

Comment 1 Alexander Larsson 2003-01-07 16:35:06 UTC
ick, did this break again.

Comment 2 Daniel Resare 2003-01-08 12:05:29 UTC
After another complete reinstall of phoebe I don't see this problem.

I did however create a new account on the old install and reproduced the problem
with a clean account. 

Unfortunately the old installation was overwritten, so I can't diff config files
or debug the problem from there.


Comment 3 Alexander Larsson 2003-01-09 11:33:37 UTC
Someone else noted the same thing, but when he changed the background it
disappeared. Needs investigation.


Comment 4 Alexander Larsson 2003-01-16 11:44:18 UTC
I believe this has been fixed in 2.1.91. Can you try it?


Comment 5 Daniel Resare 2003-01-16 17:32:59 UTC
I can try it but I'm afraid that won't tell much, since I can't reproduce the problem since the reinstall (no, I didn't save my old $HOME). Someone that experiences the problem should have a look at the updated package.

Comment 6 Bill Nottingham 2006-08-04 20:27:13 UTC
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.