Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 81102

Summary: disk druid misreports that I'm allocating more megs than I have because of calculation error of logical volumes
Product: [Retired] Red Hat Linux Reporter: Anne Fairchild <amfairc>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-05-25 14:54:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
This was the dump from anaconda when it crashed. none

Description Anne Fairchild 2003-01-04 19:55:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
I'm trying to install Red Hat 8.0.  I want to keep my logical volumes as they
are (see below.)  When I get to the Disk Druid section it reports the following.

LVM Volume Groups     File System   Size (MB)
  vg00                               31808     <-this should be 31812
    lvol4                ext2        20048
    lvol3                ext2        10240
    lvol1                ext2          500
    lvol2                ext2         1024

Hard Drives                                    
   /dev/hda
      /dev/hda1          ext2         4001
      /dev/hda2          vfat        40006
      /dev/hda3          swap          518
      /dev/hda4   vg00   LVM PV      31816     <-this should be 31812

You'll notice that the reported size of vg00 is different under the LVM heading
and the Hard Drives Heading.  This is apparently a round off error during
calculations.  You should be using the actual logical extents rather than MB
when determining how much space is used.

The output of vgdisplay -v vg00 is below.

As it is I can't install Red Hat 8.0 because of this error unless I want to do a
complete backup (which I do anyway just in case) then erase everything and start
from scratch.  I would suggest you get this fixed before 8.1.  Thank you.

--- Volume group ---
VG Name               vg00
VG Access             read/write
VG Status             available/resizable
VG #                  0
MAX LV                256
Cur LV                4
Open LV               4
MAX LV Size           255.99 GB
Max PV                256
Cur PV                1
Act PV                1
VG Size               31.07 GB
PE Size               4 MB
Total PE              7953                (7953 x 4MB = 31812MB Total)
Alloc PE / Size       7953 / 31.07 GB
Free  PE / Size       0 / 0
VG UUID               yUU51A-Qok3-tvfS-BbgZ-3ESF-yzUn-PvzB09

--- Logical volume ---
LV Name                /dev/vg00/lvol1
VG Name                vg00
LV Write Access        read/write
LV Status              available
LV #                   1
# open                 1
LV Size                500 MB
Current LE             125
Allocated LE           125
Allocation             next free
Read ahead sectors     10000
Block device           58:3

--- Logical volume ---
LV Name                /dev/vg00/lvol2
VG Name                vg00
LV Write Access        read/write
LV Status              available
LV #                   2
# open                 1
LV Size                1 GB
Current LE             256
Allocated LE           256
Allocation             next free
Read ahead sectors     10000
Block device           58:4

--- Logical volume ---
LV Name                /dev/vg00/lvol3
VG Name                vg00
LV Write Access        read/write
LV Status              available
LV #                   3
# open                 1
LV Size                10 GB
Current LE             2560
Allocated LE           2560
Allocation             next free
Read ahead sectors     10000
Block device           58:5

--- Logical volume ---
LV Name                /dev/vg00/lvol4
VG Name                vg00
LV Write Access        read/write
LV Status              available
LV #                   4
# open                 1
LV Size                19.58 GB
Current LE             5012
Allocated LE           5012
Allocation             next free
Read ahead sectors     10000
Block device           58:6


--- Physical volumes ---
PV Name (#)           /dev/hda4 (1)
PV Status             available / allocatable
Total PE / Free PE    7953 / 0


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Install onto a computer where the logical volumes are already set up 
    the same way as listed in Description.
2.  Try to set mount points and watch it crash.
3.
    

Actual Results:  It gives an error message about allocating too much hard drive
space and won't leave enough for the logical volume.

Expected Results:  The best result would be for the calculations to be done
using the actual logical extents (LE) instead of the MBs.  This would eliminate
round off errors.

I would also like to be able to tell it "I know what I'm doing.  Just do what I
tell you."

Additional info:

Comment 1 Anne Fairchild 2003-01-04 19:59:51 UTC
Created attachment 89129 [details]
This was the dump from anaconda when it crashed.

Comment 2 Jeremy Katz 2003-01-08 22:31:52 UTC
Already have changes to read preexisting sizes of volume groups in CVS

Comment 3 Anne Fairchild 2003-01-10 23:05:11 UTC
Does the beta "phoebe" incorporate these changes?  I tried phoebe and got the
same results.

Comment 4 Jeremy Katz 2003-01-10 23:50:18 UTC
Nope, change was post-phoebe

Comment 5 Brent Fox 2003-05-25 14:54:55 UTC
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.