Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 810697

Summary: no sound in lenovo ultrabase dockstation's output since 3.3.0
Product: [Fedora] Fedora Reporter: Claudio Saavedra <csaavedra>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 16CC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-15 12:19:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Claudio Saavedra 2012-04-08 12:34:04 UTC
I have a thinkpad x201 and a x200 ultrabase station and since the upgrade to 3.3.0 there is no sound coming off the output in the dockstation. Booting with 3.2.10-3 brings sound back, so this seems to be a regression in the kernel.

Comment 1 Claudio Saavedra 2012-04-13 06:29:58 UTC
This is still an issue in 3.3.1-3.

Comment 2 Claudio Saavedra 2012-04-13 06:55:11 UTC
This appears to be fixed with http://koji.fedoraproject.org/koji/taskinfo?taskID=3981036

Comment 3 Josh Boyer 2012-04-13 12:45:14 UTC
(In reply to comment #2)
> This appears to be fixed with
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3981036

Thank you for testing.  I've emailed upstream about the issue and hopefully
we'll have an official fix of sorts shortly.

Comment 4 Josh Boyer 2012-04-13 13:28:35 UTC
Claudio, upstream has a different thing for you to test if you would be so kind.

You'll need to boot back into the non-scratch-build kernel to do this, so 3.3.1-3 should be fine.

Create a file named /lib/firmware/alsa-tp-dock with the following contents:

================================================================
[codec]
0x14f15069 0x17aa21a4 0

[pincfg]
0x1a 0x21a11000
0x1c 0x23014250
================================================================

Then in /etc/modprobe.d/dist-alsa.conf, add the following:

 options snd-hda-intel patch="alsa-tp-dock"

then reboot (or rmmod/modprobe the drivers).

After the driver is loaded with that set, new mixer elements will appear.  You will need to look at the volume and mute settings for those manually.

Comment 5 Josh Boyer 2012-04-13 19:21:29 UTC
Instead, there is a new scratch build to test if you would please.  You will find it here when it finishes building:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3989218

Comment 6 Claudio Saavedra 2012-04-20 09:42:56 UTC
(In reply to comment #5)
> Instead, there is a new scratch build to test if you would please.  You will
> find it here when it finishes building:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3989218

I tried this one without doing the modifications you asked for earlier, and sound is gone. Sorry for the late reply.

Comment 7 Claudio Saavedra 2012-04-20 10:05:57 UTC
3.3.2-1, which seems to be available in the stable repo, is also broken. I tried the changes comment 4 with this and the scratch build in commend 5 without success either.

Comment 8 Josh Boyer 2012-04-20 12:49:57 UTC
With the scratch build, do new mixer devices show up?  You might have to manually adjust the mute and volume settings the first time.

Please attach alsa-info

Comment 9 Claudio Saavedra 2012-05-15 08:53:34 UTC
Seems to work with stock 3.3.4-3.fc16.x86_64 .

Comment 10 Josh Boyer 2012-05-15 12:19:14 UTC
Thanks for letting us know Claudio.