Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 81021

Summary: xconfiguration didn't work
Product: [Retired] Red Hat Linux Reporter: Rob Landry <rlandry>
Component: redhat-config-xfree86Assignee: Brent Fox <bfox>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: mharris
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:50:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Rob Landry 2003-01-03 15:53:55 UTC
Description of problem:

X works during install; but not after.  Running redhat-config-xfree86 post
install results in 

Couldn't start X server, trying with a fresh configuration
Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 1091, in ?
    xconfig = generate_xconfig(hardware_state)
  File "/usr/share/redhat-config-xfree86/xconf.py", line 855, in generate_xconfig
    get_option(corepointer, "Device").val = "/dev/" + moust.getDevice()
TypeError: cannot concatentate 'str' and 'NoneType' objects

Version-Release number of selected component (if applicable):

0.6.9-2

How reproducible:

Everytime

Steps to Reproduce:

1. Do an install
2. reboot
3. type startx
4. type redhat-config-xfree86 when step 3 fails.

Actual results:

See above.

Expected results:

X should start.

Additional info:

Video card PCI info (lspci) - 00:0f.0 VGA compatible controller: S3 Inc.
86c755/86c785 [Trio 64V2/DX or /GX] (rev 16)
Video card PCI info (lspci -n) - 00:0f.0 Class 0300: 5333:8901 (rev 16)

Startx fails with:

(II) S3: driver (version 0.3.5 for S3 chipset: 964-0, 964-1,968,
        Trio32/64, Aurora64V+
(II) Primary Device is: PCI 00:05:0
(--) Assigning device section with no busID to primary device
(EE) No devices detected.

Fatal server error:
no screens found

Comment 1 Rob Landry 2003-01-03 16:20:03 UTC
I'm able to make this work by adding 

Chipset "Trio 32/64"

to XF86Config.  At this point I'm not certain if this is a new X bug in that you
didn't need to do this before or a redhat-config-xfree86 bug in that it should
be adding this to the config file.

Comment 2 Brent Fox 2003-01-06 05:12:34 UTC
Please try with redhat-config-xfree86-0.7.1-2 in Rawhide.  I think that the
first traceback you saw is because the /etc/X11/XF86Config file doesn't exist
and the mouse cannot be probed.  I was seeing this problem on my wife's machine,
but I'm not seeing it anymore.

I think this is a dupe of bug #80115.  Please reopen this bug if the new version
doesn't fix the problem.  

*** This bug has been marked as a duplicate of 80115 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:54 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.