Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 81017

Summary: RH 8.0 Package Manager failure
Product: [Retired] Red Hat Linux Reporter: Daniel <danboy5>
Component: redhat-config-packagesAssignee: Jeremy Katz <katzj>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:50:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Daniel 2003-01-03 15:20:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
 After doing a couple of up2dates over the last couple of months, I decided to
make an atempt to remove the 'old' kernel options that appeared in the grub
loader menu at boot up. But instead of just modifying the grub config file
(hindsight!) I went into the boot directory and deleted items refering to the
older kernel versions. Since then my RPM manager (including RPM installer)
hasn't worked. It simply starts to run by bringing up the Add/Remove window,
with a checking system window in front of it. The checking system window runs
through a few things then gets to 'reading system state' at which point the
package manager disappears.......and that's it. Same thing happens when I try to
install any new RPM that I have downloaded.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run package manager or double click on any RPM file
2.
3.
    

Actual Results:   It starts to run by bringing up the Add/Remove window, with a
checking system window in front of it. The checking system window runs through a
few things then gets to 'reading system state' at which point the package
manager disappears

Expected Results:  A proper run of the RPM manager enabling me to add/remove
packages

Additional info:

Comment 1 Jeremy Katz 2003-01-03 15:37:06 UTC
Do you get any error messages if you run redhat-config-packages from a terminal
window?

Comment 2 Daniel 2003-01-03 16:02:30 UTC
I tried that command and got the following:-

Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/MainWindow.py", line 163, in ?
    comps = im.readCompsViaMethod(hdlist, progress.update)
  File "/usr/share/redhat-config-packages/method.py", line 488, in
readCompsViaMethod
    update_method = update_method)
  File "/usr/share/redhat-config-packages/comps.py", line 387, in __init__
    self.readCompsFile(file, self.packages)
  File "/usr/share/redhat-config-packages/comps.py", line 471, in readCompsFile
    self.setupStateDicts(packages)
  File "/usr/share/redhat-config-packages/comps.py", line 420, in setupStateDicts
    for prov in h[rpm.RPMTAG_PROVIDES]:
TypeError: iteration over non-sequence


Comment 3 Jeremy Katz 2003-01-03 16:16:45 UTC

*** This bug has been marked as a duplicate of 74877 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:50:53 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.