Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80972

Summary: anaconda uses too much for swap
Product: [Retired] Red Hat Linux Reporter: hjl
Component: anacondaAssignee: Michael Fulbright <msf>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: chris.ricker
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-05-25 14:58:07 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 79579    

Description hjl 2003-01-02 21:46:49 UTC
On my machine with 2GB RAM and 1.9TB HD, when I selected
the maximum allowable size for swap, I got all the
remaining 1.8TB space for swap. After I made all the
selection, I got an error on my huge swap partition.

Comment 1 Michael Fulbright 2003-01-02 22:08:58 UTC
Was this an interactive or ks-based installation?

Comment 2 hjl 2003-01-02 22:40:02 UTC
It happened during a GUI interactive install with manual
disk druid partition.

Comment 3 Matt Wilson 2003-01-06 05:00:27 UTC
"Got an error" - what was the error?

Comment 4 hjl 2003-01-06 18:39:46 UTC
I got some error later during the package installation.
It is irrelevant since anaconda shouldn't allocate a
1.8TB swap partition. It is very easy to duplicate.

Comment 5 Michael Fulbright 2003-01-14 04:54:31 UTC
I've added a 'quiet' limit to the suggested max swap size as according to
iutil.swapSuggestion() if the user specified a starting size which is smaller
than the max swap size suggestion.

Comment 6 Brent Fox 2003-05-25 14:58:07 UTC
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.