Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80932

Summary: Gedit printing results in blank page, error message
Product: [Retired] Red Hat Public Beta Reporter: Gerry Tool <gerry>
Component: geditAssignee: Havoc Pennington <hp>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: phoebeCC: marius.andreiana
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-21 02:52:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79579    

Description Gerry Tool 2003-01-02 15:18:27 UTC
Description of problem:
I can edit fine in Gedit, but when I try to print using a defined printer, a job
goes to the
printer and the result is a blank page.  Error messages like:

(gedit:6027): GnomePrint-WARNING **: Can't create GPFontEntry for
LucidaTypewriter-Bold because the extension could not be recognized
(.pcf)

appear in the terminal window from which I invoked 

gedit filename &

I have not selected LucidaTypewriter-Bold as a font to use.

I can edit and print the same file just fine from KEdit.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open GEdit
2.enter text
3.file > print, select a printer installed under cups (hpijs)
4.select print

Actual results:
job sent to printer, blank page created, error message in terminal if invoked
from CLI

Expected results:
Page should print with text

Additional info:
If Gnome Default printer is selected, printer provides output, but there is no
space between the letters.

Comment 1 Marius Andreiana 2003-01-25 09:00:50 UTC
Print preview also has a blank page

Comment 2 Havoc Pennington 2003-01-25 16:27:02 UTC
I think this may have been fixed upstream, perhaps it will be fixed 
with newer libgnomeprint22 packages

Comment 3 Seth Vidal 2003-02-12 18:37:49 UTC
Fixed in Rawhide with libgnomeprint22

Thanks
 

Comment 4 Seth Vidal 2003-02-12 18:48:06 UTC
ooo ugh.

Interesting addendum - when I print something 4 sides to a page. The page output
order is almost random.

This should probably be another bug report I guess.



Comment 5 Gerry Tool 2003-02-21 02:15:30 UTC
This bug does not seem to be present in Phoebe 3.

Comment 6 Havoc Pennington 2003-02-21 02:52:15 UTC
Thanks