Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 80926

Summary: Kword doesn't start from Gnome
Product: [Retired] Red Hat Public Beta Reporter: Gerry Tool <gerry>
Component: kofficeAssignee: Ngo Than <than>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: phoebeCC: wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-03 13:38:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 79578    

Description Gerry Tool 2003-01-02 14:25:48 UTC
Description of problem:
If I try to run Kword from Gnome, I get the following:
===============
[gerry@gstpc gerry]$ which kword
/usr/bin/kword
[gerry@gstpc gerry]$ /usr/bin/kword &
[1] 6592
[gerry@gstpc gerry]$ DCOPServer up and running.
kdeinit: Fatal IO error: client killed
kdeinit: sending SIGHUP to children.
kdeinit: sending SIGTERM to children.
kdeinit: Exit.
 
[1]+  Exit 1                  /usr/bin/kword
[gerry@gstpc gerry]$
================
If I run it from KDE, it works as expected.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use Gnome desktop
2.Execute kword
3.
    
Actual results:
KWord tries to start and dies

Expected results:
KWord should open an application window

Additional info:
Works correctly on the KDE desktop

Comment 1 Warren Togami 2003-01-23 10:13:27 UTC
Confirmed.  When you attempt to debug this, it causes a gdb internal error (Bug
82477).


Comment 2 Warren Togami 2003-01-24 19:44:06 UTC
When using koffice from a LTSP client logged into KDE I get the following error.

[patron32@kcc3 patron32]$ kword
Xlib:  extension "GLX" missing on display "ws244.ltsp:0.0".
Xlib:  extension "GLX" missing on display "ws244.ltsp:0.0".

Kword fails to start.


Comment 3 Ngo Than 2003-02-03 13:38:40 UTC
please upgrade the current kde 3.1/koffice-1.2.1 from rawhide, It seems to be
fixed in this release. I cannot reproduce it anymore.